aboutsummaryrefslogtreecommitdiffstats
path: root/wombat/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2002-11-06 05:45:39 +0800
committerChris Toshok <toshok@src.gnome.org>2002-11-06 05:45:39 +0800
commitd4bb47b0bfd07ddd7e5b72e18f21fee4d7b3a19d (patch)
tree53accced6b44b1a3d21ee3b6ff848340fd57dbee /wombat/Makefile.am
parentdfea470a8540463918fe3522e4d111fafc8d0806 (diff)
downloadgsoc2013-evolution-d4bb47b0bfd07ddd7e5b72e18f21fee4d7b3a19d.tar
gsoc2013-evolution-d4bb47b0bfd07ddd7e5b72e18f21fee4d7b3a19d.tar.gz
gsoc2013-evolution-d4bb47b0bfd07ddd7e5b72e18f21fee4d7b3a19d.tar.bz2
gsoc2013-evolution-d4bb47b0bfd07ddd7e5b72e18f21fee4d7b3a19d.tar.lz
gsoc2013-evolution-d4bb47b0bfd07ddd7e5b72e18f21fee4d7b3a19d.tar.xz
gsoc2013-evolution-d4bb47b0bfd07ddd7e5b72e18f21fee4d7b3a19d.tar.zst
gsoc2013-evolution-d4bb47b0bfd07ddd7e5b72e18f21fee4d7b3a19d.zip
change over from .oaf files to .server files and remove the moniker stuff
2002-11-05 Chris Toshok <toshok@ximian.com> * Makefile.am: change over from .oaf files to .server files and remove the moniker stuff from the build. * wombat.c: port over to gnome2, and nuke all the config moniker stuff. * wombat-moniker.[ch]: remove * wombat-private-moniker.[ch]: remove * GNOME_Evolution_WombatLDAP.server.in: rename the oaf.in file to this. * GNOME_Evolution_WombatNOLDAP.server.in: rename the oaf.in file to this. * .cvsignore: s/oaf/server svn path=/trunk/; revision=18568
Diffstat (limited to 'wombat/Makefile.am')
-rw-r--r--wombat/Makefile.am26
1 files changed, 13 insertions, 13 deletions
diff --git a/wombat/Makefile.am b/wombat/Makefile.am
index 46438d7f2d..a360e76e85 100644
--- a/wombat/Makefile.am
+++ b/wombat/Makefile.am
@@ -1,5 +1,9 @@
INCLUDES = \
-DG_LOG_DOMAIN=\"wombat\" \
+ -DPREFIX=\"$(prefix)\" \
+ -DSYSCONFDIR=\"$(sysconfdir)\" \
+ -DDATADIR=\"$(datadir)\" \
+ -DLIBDIR=\"$(libdir)\" \
-I$(top_srcdir)/e-util \
-I$(top_srcdir) \
-I$(top_srcdir)/addressbook/backend \
@@ -17,10 +21,6 @@ bin_PROGRAMS = \
wombat
wombat_SOURCES = \
- wombat-moniker.c \
- wombat-moniker.h \
- wombat-private-moniker.c \
- wombat-private-moniker.h \
wombat.c
if ENABLE_LDAP
@@ -47,28 +47,28 @@ wombat_LDADD = \
$(top_builddir)/libwombat/libwombat.la \
$(WOMBAT_LIBS)
-oafdir = $(datadir)/oaf
+serversdir = $(libdir)/bonobo/servers
if ENABLE_LDAP
-OAF_IN_FILE=GNOME_Evolution_WombatLDAP.oaf.in
+SERVER_IN_FILE=GNOME_Evolution_WombatLDAP.server.in
else
-OAF_IN_FILE=GNOME_Evolution_WombatNOLDAP.oaf.in
+SERVER_IN_FILE=GNOME_Evolution_WombatNOLDAP.server.in
endif
-GNOME_Evolution_Wombat.oaf.in: $(OAF_IN_FILE)
+GNOME_Evolution_Wombat.server.in: $(SERVER_IN_FILE)
cp $< $@
-oaf_in_files = GNOME_Evolution_Wombat.oaf.in
-oaf_DATA = $(oaf_in_files:.oaf.in=.oaf)
+server_in_files = GNOME_Evolution_Wombat.server.in
+servers_DATA = $(server_in_files:.server.in=.server)
-@XML_I18N_MERGE_OAF_RULE@
+@INTLTOOL_SERVER_RULE@
idldir = $(datadir)/idl
idl_DATA = Evolution-Wombat.idl
-EXTRA_DIST = $(oaf_DATA) $(oaf_in_files) $(idl_DATA) \
- GNOME_Evolution_WombatLDAP.oaf.in GNOME_Evolution_WombatNOLDAP.oaf.in
+EXTRA_DIST = $(servers_DATA) $(server_in_files) $(idl_DATA) \
+ GNOME_Evolution_WombatLDAP.server.in GNOME_Evolution_WombatNOLDAP.server.in
if ENABLE_PURIFY
PLINK = $(LIBTOOL) --mode=link $(PURIFY) $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@