aboutsummaryrefslogtreecommitdiffstats
path: root/win32/Makefile.am
diff options
context:
space:
mode:
authorFridrich Strba <fridrich.strba@bluewin.ch>2010-01-28 15:01:13 +0800
committerFridrich Strba <fridrich.strba@bluewin.ch>2010-01-28 21:48:36 +0800
commit013ce5b70e85d6c9008cebd1d5efbe87a539d445 (patch)
tree220c399960ff4583071c14097e10389e42c5db59 /win32/Makefile.am
parent8bbc48cd7792901c406cf8f773372508677ceb93 (diff)
downloadgsoc2013-evolution-013ce5b70e85d6c9008cebd1d5efbe87a539d445.tar
gsoc2013-evolution-013ce5b70e85d6c9008cebd1d5efbe87a539d445.tar.gz
gsoc2013-evolution-013ce5b70e85d6c9008cebd1d5efbe87a539d445.tar.bz2
gsoc2013-evolution-013ce5b70e85d6c9008cebd1d5efbe87a539d445.tar.lz
gsoc2013-evolution-013ce5b70e85d6c9008cebd1d5efbe87a539d445.tar.xz
gsoc2013-evolution-013ce5b70e85d6c9008cebd1d5efbe87a539d445.tar.zst
gsoc2013-evolution-013ce5b70e85d6c9008cebd1d5efbe87a539d445.zip
Without this evo 2.28.2 will not link/run at all
The change is needed: 1) To export the right symbols from the right dummy import library so that the loader does not look for symbols where they are not 2) Export that comp_editor_registry using a getter function for win32 so that we don't have to decorate the data string so that the autoexport works again
Diffstat (limited to 'win32/Makefile.am')
-rw-r--r--win32/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/win32/Makefile.am b/win32/Makefile.am
index 7720d56543..ba405e0f9e 100644
--- a/win32/Makefile.am
+++ b/win32/Makefile.am
@@ -5,6 +5,7 @@ EXTRA_DIST = \
libetext.def \
libevolution-addressbook.def \
libevolution-calendar.def \
+ libevolution-cal-shared.def \
libevolution-mail.def \
libfilter.def
@@ -15,6 +16,7 @@ BOOTSTRAP_LIBS = \
libetext.la \
libevolution-addressbook.la \
libevolution-calendar.la \
+ libevolution-cal-shared.la \
libevolution-mail.la \
libfilter.la
endif
@@ -51,6 +53,11 @@ libevolution-calendar.la: dummy.la libevolution-calendar.def
mkdir -p .libs
$(DLLTOOL) --output-lib=.libs/libevolution-calendar.dll.a --dllname=libevolution-calendar.dll --input-def=libevolution-calendar.def
+libevolution-cal-shared.la: dummy.la libevolution-cal-shared.def
+ sed -e s!%DLL%!libevolution-cal-shared-0! -e s!%LIB%!libevolution-cal-shared! -e s!%PFX%!$(prefix)! <dummy.la >$@
+ mkdir -p .libs
+ $(DLLTOOL) --output-lib=.libs/libevolution-cal-shared.dll.a --dllname=libevolution-cal-shared-0.dll --input-def=libevolution-cal-shared.def
+
libevolution-mail.la: dummy.la libevolution-mail.def
sed -e s!%DLL%!libevolution-mail! -e s!%LIB%!libevolution-mail! -e s!%PFX%!$(prefix)! <dummy.la >$@
mkdir -p .libs