aboutsummaryrefslogtreecommitdiffstats
path: root/widgets/misc/Makefile.am
diff options
context:
space:
mode:
authorDamon Chaplin <damon@helixcode.com>2000-09-11 07:22:51 +0800
committerDamon Chaplin <damon@src.gnome.org>2000-09-11 07:22:51 +0800
commit3ef38d9cc08d0dc1e0e94bfc8b01ca78416bae30 (patch)
treefa70f00a162a910ba8c1e7f67f8f3262d446c3b0 /widgets/misc/Makefile.am
parent04b9887c41506d308aac7b89858b3bd5a4bb9ec4 (diff)
downloadgsoc2013-evolution-3ef38d9cc08d0dc1e0e94bfc8b01ca78416bae30.tar
gsoc2013-evolution-3ef38d9cc08d0dc1e0e94bfc8b01ca78416bae30.tar.gz
gsoc2013-evolution-3ef38d9cc08d0dc1e0e94bfc8b01ca78416bae30.tar.bz2
gsoc2013-evolution-3ef38d9cc08d0dc1e0e94bfc8b01ca78416bae30.tar.lz
gsoc2013-evolution-3ef38d9cc08d0dc1e0e94bfc8b01ca78416bae30.tar.xz
gsoc2013-evolution-3ef38d9cc08d0dc1e0e94bfc8b01ca78416bae30.tar.zst
gsoc2013-evolution-3ef38d9cc08d0dc1e0e94bfc8b01ca78416bae30.zip
added e-dateedit.[hc] and the test-dateedit app.
2000-09-11 Damon Chaplin <damon@helixcode.com> * Makefile.am (libemiscwidgets_a_SOURCES): added e-dateedit.[hc] and the test-dateedit app. * e-dateedit.[hc]: new widget to use instead of GnomeDateEdit. It uses the new ECalendar widget for the calendar and also supports "None", "Today" and "Now" buttons, and goes away with a single click. * test-dateedit.c: app to test the EDateEdit widget. * e-calendar-item.c: updated to support the EDateEdit better, mainly by adding the "move_selection_when_moving" arg so we can turn it off to keep the same day selected when changing the months shown. svn path=/trunk/; revision=5304
Diffstat (limited to 'widgets/misc/Makefile.am')
-rw-r--r--widgets/misc/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/widgets/misc/Makefile.am b/widgets/misc/Makefile.am
index e2872e7006..1fd1008c9e 100644
--- a/widgets/misc/Makefile.am
+++ b/widgets/misc/Makefile.am
@@ -17,6 +17,8 @@ libemiscwidgets_a_SOURCES = \
e-calendar-item.h \
e-clipped-label.c \
e-clipped-label.h \
+ e-dateedit.c \
+ e-dateedit.h \
e-scroll-frame.c \
e-scroll-frame.h \
e-title-bar.c \
@@ -24,7 +26,8 @@ libemiscwidgets_a_SOURCES = \
noinst_PROGRAMS = \
test-title-bar \
- test-calendar
+ test-calendar \
+ test-dateedit
test_title_bar_SOURCES = \
test-title-bar.c
@@ -40,3 +43,12 @@ test_calendar_LDADD = \
./libemiscwidgets.a \
../../e-util/libeutil.la \
$(EXTRA_GNOME_LIBS)
+
+test_dateedit_SOURCES = \
+ test-dateedit.c
+
+test_dateedit_LDADD = \
+ ./libemiscwidgets.a \
+ ../../e-util/libeutil.la \
+ $(EXTRA_GNOME_LIBS)
+