aboutsummaryrefslogtreecommitdiffstats
path: root/widgets/misc/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2004-05-12 11:36:37 +0800
committerMichael Zucci <zucchi@src.gnome.org>2004-05-12 11:36:37 +0800
commit72dbc81f48008909473e67eb23e61e05ff4d8057 (patch)
tree7ae2ce7aabf1c82da3ff9f8de2284966f9edb6e0 /widgets/misc/Makefile.am
parent97926d706a599a789b8d7b03a9e41a20513659d1 (diff)
downloadgsoc2013-evolution-72dbc81f48008909473e67eb23e61e05ff4d8057.tar
gsoc2013-evolution-72dbc81f48008909473e67eb23e61e05ff4d8057.tar.gz
gsoc2013-evolution-72dbc81f48008909473e67eb23e61e05ff4d8057.tar.bz2
gsoc2013-evolution-72dbc81f48008909473e67eb23e61e05ff4d8057.tar.lz
gsoc2013-evolution-72dbc81f48008909473e67eb23e61e05ff4d8057.tar.xz
gsoc2013-evolution-72dbc81f48008909473e67eb23e61e05ff4d8057.tar.zst
gsoc2013-evolution-72dbc81f48008909473e67eb23e61e05ff4d8057.zip
make the Because cases the same.
2004-05-12 Not Zed <NotZed@Ximian.com> * e-system-errors.xml: make the Because cases the same. * e-system-errors.xml.h: add for translators. * e-error.c (ee_load): just use _() to do i18n rather than the nasty lang stuff. (find_node): no longer needed. * Makefile.am (%.xml.h): setup the build rules for the i18n file for the errors. * e-system-errors.xml.in: Removed, renamed to .xml and removed the _ stuff. svn path=/trunk/; revision=25871
Diffstat (limited to 'widgets/misc/Makefile.am')
-rw-r--r--widgets/misc/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/widgets/misc/Makefile.am b/widgets/misc/Makefile.am
index cacf891cba..57b552b67a 100644
--- a/widgets/misc/Makefile.am
+++ b/widgets/misc/Makefile.am
@@ -72,10 +72,11 @@ libemiscwidgets_la_SOURCES = \
MARSHAL_GENERATED = e-util-marshal.c e-util-marshal.h
@EVO_MARSHAL_RULE@
-error_in_files = e-system-errors.xml.in
-error_DATA = $(error_in_files:.xml.in=.xml)
+error_DATA = e-system-errors.xml
+error_i18n = $(error_DATA:.xml=.xml.h)
errordir = $(privdatadir)/errors
-@INTLTOOL_XML_RULE@
+%.xml.h: %.xml
+ $(top_builddir)/e-util/e-error-tool $^
libemiscwidgets_la_LIBADD = $(top_builddir)/e-util/libeutil.la \
$(top_builddir)/a11y/widgets/libevolution-widgets-a11y.la \
@@ -176,11 +177,12 @@ test_error_LDADD = \
$(GNOME_FULL_LIBS)
-BUILT_SOURCES = $(MARSHAL_GENERATED) $(error_DATA)
+BUILT_SOURCES = $(MARSHAL_GENERATED) $(error_i18n)
CLEANFILES = $(BUILT_SOURCES)
EXTRA_DIST = \
- $(error_in_files) \
+ $(error_DATA) \
+ $(error_i18n) \
e-util-marshal.list \
ChangeLog.pre-1-4