aboutsummaryrefslogtreecommitdiffstats
path: root/widgets/misc/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2007-12-02 09:41:04 +0800
committerMatthew Barnes <mbarnes@src.gnome.org>2007-12-02 09:41:04 +0800
commit8266bb685a189d8560450ff161efdd5629849f11 (patch)
treef86f9368649f2a036730a704fb97c12160c10365 /widgets/misc/Makefile.am
parent253452654a4bc2fdd44f61446890ccf556c82958 (diff)
downloadgsoc2013-evolution-8266bb685a189d8560450ff161efdd5629849f11.tar
gsoc2013-evolution-8266bb685a189d8560450ff161efdd5629849f11.tar.gz
gsoc2013-evolution-8266bb685a189d8560450ff161efdd5629849f11.tar.bz2
gsoc2013-evolution-8266bb685a189d8560450ff161efdd5629849f11.tar.lz
gsoc2013-evolution-8266bb685a189d8560450ff161efdd5629849f11.tar.xz
gsoc2013-evolution-8266bb685a189d8560450ff161efdd5629849f11.tar.zst
gsoc2013-evolution-8266bb685a189d8560450ff161efdd5629849f11.zip
** Fixes part of bug #495123
2007-12-01 Matthew Barnes <mbarnes@redhat.com> ** Fixes part of bug #495123 * composer/e-msg-composer.c: * composer/e-msg-composer-hdrs.h: * composer/e-msg-composer-hdrs.c: Move signature handling to e-msg-composer-hdrs.c. Use an ESignatureComboBox. * composer/e-composer-from-header.h: * composer/e-composer-from-header.c: Clean up the GtkHBox hack. The signature combo is now packed directly into the GtkTable. * composer/e-composer-name-header.c: * composer/e-composer-text-header.c: Code cleanup. * widgets/misc/Makefile.am: Add e-signature-combo-box.[ch]. * widget/misc/e-account-combo-box.c (account_combo_box_refresh_cb): Make sure the EAccount isn't lost while swapping models. * widget/misc/e-signature-combo-box.c: * widget/misc/e-signature-combo-box.h: New widget renders an ESignatureList as a combo box. Also listens for changes to the ESignatureList and updates itself accordingly. svn path=/trunk/; revision=34620
Diffstat (limited to 'widgets/misc/Makefile.am')
-rw-r--r--widgets/misc/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/widgets/misc/Makefile.am b/widgets/misc/Makefile.am
index c35d7a9f2c..267ded9aab 100644
--- a/widgets/misc/Makefile.am
+++ b/widgets/misc/Makefile.am
@@ -76,6 +76,7 @@ widgetsinclude_HEADERS = \
e-selection-model-array.h \
e-selection-model-simple.h \
e-selection-model.h \
+ e-signature-combo-box.h \
e-unicode.h \
e-colors.h
@@ -122,6 +123,7 @@ libemiscwidgets_la_SOURCES = \
e-selection-model-array.c \
e-selection-model-simple.c \
e-selection-model.c \
+ e-signature-combo-box.c \
e-unicode.c \
e-colors.c
@@ -136,6 +138,7 @@ libemiscwidgets_la_LIBADD = $(top_builddir)/e-util/libeutil.la \
$(top_builddir)/a11y/libevolution-a11y.la \
$(CAMEL_LIBS) \
$(GNOME_PLATFORM_LIBS) \
+ $(EVOLUTON_MAIL_LIBS) \
$(ICONV_LIBS)
libefilterbar_la_SOURCES = \