aboutsummaryrefslogtreecommitdiffstats
path: root/widgets/misc/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@src.gnome.org>2009-04-01 05:48:38 +0800
committerMatthew Barnes <mbarnes@src.gnome.org>2009-04-01 05:48:38 +0800
commit0485fb58c5beeb04f0b3d833e6b73a2d2ec1acc7 (patch)
tree90df407868f6e2636e064af23f3a8560b143ddf5 /widgets/misc/Makefile.am
parent04cc4a2cb1bf87417f82d1094ddde611019c0ab8 (diff)
downloadgsoc2013-evolution-0485fb58c5beeb04f0b3d833e6b73a2d2ec1acc7.tar
gsoc2013-evolution-0485fb58c5beeb04f0b3d833e6b73a2d2ec1acc7.tar.gz
gsoc2013-evolution-0485fb58c5beeb04f0b3d833e6b73a2d2ec1acc7.tar.bz2
gsoc2013-evolution-0485fb58c5beeb04f0b3d833e6b73a2d2ec1acc7.tar.lz
gsoc2013-evolution-0485fb58c5beeb04f0b3d833e6b73a2d2ec1acc7.tar.xz
gsoc2013-evolution-0485fb58c5beeb04f0b3d833e6b73a2d2ec1acc7.tar.zst
gsoc2013-evolution-0485fb58c5beeb04f0b3d833e6b73a2d2ec1acc7.zip
Extend EAttachmentView by subclassing EAttachmentHandler.
So far it only supports extending the attachment pop-up menu, but I also plan to support extending drag and drop types. Might even end up replacing EMFormatHook. Two subclasses created so far: EAttachmentHandlerImage handles images (built-in) EAttachmentHandlerMail handles emails (defined in mail module) svn path=/branches/kill-bonobo/; revision=37487
Diffstat (limited to 'widgets/misc/Makefile.am')
-rw-r--r--widgets/misc/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/widgets/misc/Makefile.am b/widgets/misc/Makefile.am
index f6fc7ed10a..ad2f445eea 100644
--- a/widgets/misc/Makefile.am
+++ b/widgets/misc/Makefile.am
@@ -41,6 +41,8 @@ widgetsinclude_HEADERS = \
e-alert-activity.h \
e-attachment.h \
e-attachment-dialog.h \
+ e-attachment-handler.h \
+ e-attachment-handler-image.h \
e-attachment-icon-view.h \
e-attachment-paned.h \
e-attachment-store.h \
@@ -103,6 +105,8 @@ libemiscwidgets_la_SOURCES = \
e-alert-activity.c \
e-attachment.c \
e-attachment-dialog.c \
+ e-attachment-handler.c \
+ e-attachment-handler-image.c \
e-attachment-icon-view.c \
e-attachment-paned.c \
e-attachment-store.c \