aboutsummaryrefslogtreecommitdiffstats
path: root/widgets/misc/Makefile.am
diff options
context:
space:
mode:
authorKaushal Kumar <kakumar@novell.com>2005-06-17 23:20:35 +0800
committerKaushal Kumar <kaushal@src.gnome.org>2005-06-17 23:20:35 +0800
commit27a61acf278caf11e5e203d4ee13e107d5b84b2d (patch)
tree3cfc4a916ecfd4d75587e6939b4e4990a35eb5d1 /widgets/misc/Makefile.am
parent5a7ddf3c6dab1474185d7c92a1413601878eb690 (diff)
downloadgsoc2013-evolution-27a61acf278caf11e5e203d4ee13e107d5b84b2d.tar
gsoc2013-evolution-27a61acf278caf11e5e203d4ee13e107d5b84b2d.tar.gz
gsoc2013-evolution-27a61acf278caf11e5e203d4ee13e107d5b84b2d.tar.bz2
gsoc2013-evolution-27a61acf278caf11e5e203d4ee13e107d5b84b2d.tar.lz
gsoc2013-evolution-27a61acf278caf11e5e203d4ee13e107d5b84b2d.tar.xz
gsoc2013-evolution-27a61acf278caf11e5e203d4ee13e107d5b84b2d.tar.zst
gsoc2013-evolution-27a61acf278caf11e5e203d4ee13e107d5b84b2d.zip
Retired GAL from Head. The relevant files have moved inside evolution.
2005-06-17 Kaushal Kumar <kakumar@novell.com> * Retired GAL from Head. The relevant files have moved inside evolution. Thanks to JP Rosevear for performing the cvs surgery. The files have been moved in the following order. evolution/e-util <- gal/gal/util evolution/a11y <- gal/gal/a11y evolution/a11y/e-table <- gal/gal/a11y/e-table evolution/a11y/e-text <- gal/gal/a11y/e-text evolution/widgets/table <- gal/gal/e-table evolution/widgets/text <- gal/gal/e-text evolution/widgets/misc <- gal/gal/widgets evolution/widgets/misc/pixmaps <- gal/gal/widgets/pixmaps evolution/widgets/menus <- gal/gal/menus Following is the summary of changes done to fix the build:- - New files added to cvs repository, - a11y/e-table/Makefile.am - a11y/e-text/Makefile.am - widgets/table/Makefile.am - widgets/text/Makefile.am - widgets/misc/pixmaps/Makefile.am - iconv-detect.h - iconv-detect.c - Updated configure.in. - Updated all the relevant Makefile.am files. - Updated the include paths to replace all gal references. - Updated the marshal list to suit gal files requirements. svn path=/trunk/; revision=29522
Diffstat (limited to 'widgets/misc/Makefile.am')
-rw-r--r--widgets/misc/Makefile.am60
1 files changed, 55 insertions, 5 deletions
diff --git a/widgets/misc/Makefile.am b/widgets/misc/Makefile.am
index 03ab98864f..73095b8432 100644
--- a/widgets/misc/Makefile.am
+++ b/widgets/misc/Makefile.am
@@ -1,11 +1,16 @@
INCLUDES = \
-I$(top_srcdir) \
- -I$(top_srcdir)/a11y/widgets/ \
+ -I$(top_srcdir)/a11y/widgets \
+ -I$(top_srcdir)/widgets/ \
-DMAP_DIR=\""$(imagesdir)"\" \
-DEVOLUTION_PRIVDATADIR=\""$(privdatadir)"\" \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
-DG_LOG_DOMAIN=__FILE__ \
- $(E_WIDGETS_CFLAGS)
+ $(E_WIDGETS_CFLAGS) \
+ $(EXTRA_GNOME_CFLAGS) \
+ $(ICONV_CFLAGS)
+
privlib_LTLIBRARIES = \
libemiscwidgets.la \
@@ -21,7 +26,11 @@ pilot_sources =
pilot_headers =
endif
-glade_DATA = e-send-options.glade
+glade_DATA = e-send-options.glade \
+ gal-categories.glade
+
+libemiscwidgets_la_LDFLAGS = $(ICONV_LIBS)
+
widgetsinclude_HEADERS = \
$(pilot_headers) \
@@ -47,7 +56,25 @@ widgetsinclude_HEADERS = \
e-task-bar.h \
e-task-widget.h \
e-send-options.h \
- e-url-entry.h
+ e-url-entry.h \
+ e-canvas-background.h \
+ e-canvas-utils.h \
+ e-canvas-vbox.h \
+ e-canvas.h \
+ e-cursors.h \
+ e-gui-utils.h \
+ e-hsv-utils.h \
+ e-popup-menu.h \
+ e-printable.h \
+ e-reflow-model.h \
+ e-reflow.h \
+ e-selection-model-array.h \
+ e-selection-model-simple.h \
+ e-selection-model.h \
+ e-unicode.h \
+ e-colors.h \
+ gal-combo-box.h \
+ gal-combo-text.h
libemiscwidgets_la_SOURCES = \
$(MARSHAL_GENERATED) \
@@ -75,13 +102,34 @@ libemiscwidgets_la_SOURCES = \
e-task-bar.c \
e-task-widget.c \
e-send-options.c \
- e-url-entry.c
+ e-url-entry.c \
+ e-canvas-background.c \
+ e-canvas-utils.c \
+ e-canvas-vbox.c \
+ e-canvas.c \
+ e-cursors.c \
+ e-gui-utils.c \
+ e-hsv-utils.c \
+ e-popup-menu.c \
+ e-printable.c \
+ e-reflow-model.c \
+ e-reflow.c \
+ e-selection-model-array.c \
+ e-selection-model-simple.c \
+ e-selection-model.c \
+ e-unicode.c \
+ e-colors.c \
+ gal-combo-box.c \
+ gal-combo-text.c
MARSHAL_GENERATED = e-util-marshal.c e-util-marshal.h
@EVO_MARSHAL_RULE@
libemiscwidgets_la_LIBADD = $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/widgets/table/libetable.la \
+ $(top_builddir)/widgets/text/libetext.la \
$(top_builddir)/a11y/widgets/libevolution-widgets-a11y.la \
+ $(top_builddir)/a11y/libevolution-a11y.la \
$(E_WIDGETS_LIBS)
libefilterbar_la_SOURCES = \
@@ -156,4 +204,6 @@ EXTRA_DIST = \
ChangeLog.pre-1-4
dist-hook:
+ -mkdir $(distdir)/pixmaps
+ cp $(srcdir)/pixmaps/*.xpm $(distdir)/pixmaps
cd $(distdir); rm -f $(BUILT_SOURCES)