aboutsummaryrefslogtreecommitdiffstats
path: root/widgets/misc/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2002-11-07 12:52:05 +0800
committerChris Toshok <toshok@src.gnome.org>2002-11-07 12:52:05 +0800
commitb59fb51176c10c48865572b27d697c6cc51358d3 (patch)
tree71fbf1b2db990dda2316c7dd7d31024171b2160f /widgets/misc/Makefile.am
parentdaf38bc8b0643edaf1629f7767ddb3051821d000 (diff)
downloadgsoc2013-evolution-b59fb51176c10c48865572b27d697c6cc51358d3.tar
gsoc2013-evolution-b59fb51176c10c48865572b27d697c6cc51358d3.tar.gz
gsoc2013-evolution-b59fb51176c10c48865572b27d697c6cc51358d3.tar.bz2
gsoc2013-evolution-b59fb51176c10c48865572b27d697c6cc51358d3.tar.lz
gsoc2013-evolution-b59fb51176c10c48865572b27d697c6cc51358d3.tar.xz
gsoc2013-evolution-b59fb51176c10c48865572b27d697c6cc51358d3.tar.zst
gsoc2013-evolution-b59fb51176c10c48865572b27d697c6cc51358d3.zip
ignore the generated marshal source.
2002-11-06 Chris Toshok <toshok@ximian.com> * .cvsignore: ignore the generated marshal source. * Makefile.am: add marshal stuff. * e-util-marshal.list: marshaller list. * e-search-bar.[ch]: gobjectify this. svn path=/trunk/; revision=18627
Diffstat (limited to 'widgets/misc/Makefile.am')
-rw-r--r--widgets/misc/Makefile.am21
1 files changed, 20 insertions, 1 deletions
diff --git a/widgets/misc/Makefile.am b/widgets/misc/Makefile.am
index 7e02313f13..9ea28e8f38 100644
--- a/widgets/misc/Makefile.am
+++ b/widgets/misc/Makefile.am
@@ -49,7 +49,22 @@ libemiscwidgets_a_SOURCES = \
e-multi-config-dialog.c \
e-search-bar.c \
e-title-bar.c \
- e-url-entry.c
+ e-url-entry.c \
+ e-util-marshal.c
+
+# GLib marshalling cruft
+
+e-util-marshal.h: e-util-marshal.list
+ ( @GLIB_GENMARSHAL@ --prefix=e_util_marshal e-util-marshal.list --header > e-util-marshal.tmp \
+ && mv e-util-marshal.tmp e-util-marshal.h ) \
+ || ( rm -f e-util-marshal.tmp && exit 1 )
+
+e-util-marshal.c: e-util-marshal.h
+ ( @GLIB_GENMARSHAL@ --prefix=e_util_marshal e-util-marshal.list --body > e-util-marshal.tmp \
+ && mv e-util-marshal.tmp e-util-marshal.c ) \
+ || ( rm -f e-util-marshal.tmp && exit 1 )
+
+MARSHAL_GENERATED = e-util-marshal.c e-util-marshal.h
libemiscwidgets_a_LIBADD = $(top_builddir)/e-util/libeutil.la
@@ -114,3 +129,7 @@ test_title_bar_LDADD = \
$(GNOME_FULL_LIBS)
+BUILT_SOURCES = $(MARSHAL_GENERATED)
+CLEANFILES = $(BUILT_SOURCES)
+
+EXTRA_DIST = e-book-marshal.list