aboutsummaryrefslogtreecommitdiffstats
path: root/widgets/e-table/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@helixcode.com>2000-06-11 12:20:56 +0800
committerChris Toshok <toshok@src.gnome.org>2000-06-11 12:20:56 +0800
commitaac3f2c8b69f579e04314b21a13d752afe4bd317 (patch)
treedec49e04bac8721e060f07003aa90bcb76d30479 /widgets/e-table/Makefile.am
parent835ec00d01e23256143229d8e2c99f68afae1e6c (diff)
downloadgsoc2013-evolution-aac3f2c8b69f579e04314b21a13d752afe4bd317.tar
gsoc2013-evolution-aac3f2c8b69f579e04314b21a13d752afe4bd317.tar.gz
gsoc2013-evolution-aac3f2c8b69f579e04314b21a13d752afe4bd317.tar.bz2
gsoc2013-evolution-aac3f2c8b69f579e04314b21a13d752afe4bd317.tar.lz
gsoc2013-evolution-aac3f2c8b69f579e04314b21a13d752afe4bd317.tar.xz
gsoc2013-evolution-aac3f2c8b69f579e04314b21a13d752afe4bd317.tar.zst
gsoc2013-evolution-aac3f2c8b69f579e04314b21a13d752afe4bd317.zip
change things so we focus the cell and select the row, and also dispatch
2000-06-10 Chris Toshok <toshok@helixcode.com> * e-table-item.c (eti_event): change things so we focus the cell and select the row, and also dispatch the event to that row/cell. This fixes the problem with the tree where you had to click twice to activate the tree controls. * Makefile.am (libetable_a_SOURCES): remove e-tree-gnode.* and add e-tree-simple.* (icons): add tree-expanded.xpm and tree-unexpanded.xpm * e-cell-tree.c (ect_enter_edit): defer to subcell's view. (ect_leave_edit): defer to subcell's view. (visible_depth_of_node): visual depth, taking into account that the root node of the model might not be displayed. (offset_of_node): return the offset used to shift the subcell over. (ect_draw): don't draw vertical lines if we're the leftmode node (a visual root node). also, don't shift x2 by the subcell offset, so we get ellipses like we're supposed to. (ect_event): remove GDK_BUTTON_RELEASE from the list of events that we care about. * e-tree-example-1.c: lots of changes, a more dynamic UI so we can test tree model api stuff. * e-tree-gnode.c, e-tree-gnode.c: removed files, since their guts have been rolled into e-tree-model.c * e-tree-model.c, e-tree-model.h: substantially changed. too much to really describe here. this should really be considered the first revision of these files :) * e-tree-simple.c, e-tree-simple.h: analogous to e-table-simple, a subclass that allows the use of function pointers. svn path=/trunk/; revision=3519
Diffstat (limited to 'widgets/e-table/Makefile.am')
-rw-r--r--widgets/e-table/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/widgets/e-table/Makefile.am b/widgets/e-table/Makefile.am
index 9f21f45cd2..65504749ba 100644
--- a/widgets/e-table/Makefile.am
+++ b/widgets/e-table/Makefile.am
@@ -76,10 +76,10 @@ libetable_a_SOURCES = \
e-table-subset-variable.h \
e-table-text-model.c \
e-table-text-model.h \
- e-tree-gnode.c \
- e-tree-gnode.h \
e-tree-model.c \
- e-tree-model.h
+ e-tree-model.h \
+ e-tree-simple.c \
+ e-tree-simple.h
noinst_PROGRAMS = \
table-test table-example-1 table-example-2 table-size-test tree-example-1
@@ -159,7 +159,9 @@ icons = \
add-col.xpm \
check-empty.xpm \
check-filled.xpm \
- remove-col.xpm
+ remove-col.xpm \
+ tree-expanded.xpm \
+ tree-unexpanded.xpm
EXTRA_DIST = \
sample.table \