aboutsummaryrefslogtreecommitdiffstats
path: root/widgets/e-table/Makefile.am
diff options
context:
space:
mode:
authorChristopher James Lahey <clahey@helixcode.com>2000-03-01 05:07:06 +0800
committerChris Lahey <clahey@src.gnome.org>2000-03-01 05:07:06 +0800
commit832150b0dda320f18f1aedf2da23d0b087cde748 (patch)
treea81426b3f8f314cdd91eb152072ab5d53f9e3c2b /widgets/e-table/Makefile.am
parent2f6721bf5bd7d5c853279db40b1fb15ded4745a2 (diff)
downloadgsoc2013-evolution-832150b0dda320f18f1aedf2da23d0b087cde748.tar
gsoc2013-evolution-832150b0dda320f18f1aedf2da23d0b087cde748.tar.gz
gsoc2013-evolution-832150b0dda320f18f1aedf2da23d0b087cde748.tar.bz2
gsoc2013-evolution-832150b0dda320f18f1aedf2da23d0b087cde748.tar.lz
gsoc2013-evolution-832150b0dda320f18f1aedf2da23d0b087cde748.tar.xz
gsoc2013-evolution-832150b0dda320f18f1aedf2da23d0b087cde748.tar.zst
gsoc2013-evolution-832150b0dda320f18f1aedf2da23d0b087cde748.zip
Test frozen columns
2000-02-29 Christopher James Lahey <clahey@helixcode.com> * test-table.c: Test frozen columns * e-table.c: Make frozen columns available through the xml file. * e-table-header.c, e-table-header.h, e-table-header-item.c: Added frozen columns API to let you specify some number of leading columns as undraggable. * Makefile.am: Add e-table-example-1.c and e-table-example-2.c. * e-table-example-1.c, e-table-example-2.c: New files. A couple of examples of ETable use. svn path=/trunk/; revision=1993
Diffstat (limited to 'widgets/e-table/Makefile.am')
-rw-r--r--widgets/e-table/Makefile.am24
1 files changed, 23 insertions, 1 deletions
diff --git a/widgets/e-table/Makefile.am b/widgets/e-table/Makefile.am
index a231708564..4364c1fbc0 100644
--- a/widgets/e-table/Makefile.am
+++ b/widgets/e-table/Makefile.am
@@ -47,7 +47,7 @@ libetable_a_SOURCES = \
e-table-subset-variable.h
noinst_PROGRAMS = \
- table-test
+ table-test table-example-1 table-example-2
table_test_SOURCES = \
test-table.c \
@@ -63,6 +63,28 @@ table_test_LDADD = \
table_test_LDFLAGS = `gnome-config --libs gdk_pixbuf`
+table_example_1_SOURCES = \
+ e-table-example-1.c
+
+table_example_1_LDADD = \
+ libetable.a \
+ $(EXTRA_GNOME_LIBS) \
+ $(top_builddir)/e-util/libeutil.a \
+ $(top_builddir)/widgets/e-text/libetext.a
+
+table_example_1_LDFLAGS = `gnome-config --libs gdk_pixbuf`
+
+table_example_2_SOURCES = \
+ e-table-example-2.c
+
+table_example_2_LDADD = \
+ libetable.a \
+ $(EXTRA_GNOME_LIBS) \
+ $(top_builddir)/e-util/libeutil.a \
+ $(top_builddir)/widgets/e-text/libetext.a
+
+table_example_2_LDFLAGS = `gnome-config --libs gdk_pixbuf`
+
EXTRA_DIST = \
sample.table \
add-col.xpm \