aboutsummaryrefslogtreecommitdiffstats
path: root/widgets/e-table/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@helixcode.com>2000-09-01 17:05:56 +0800
committerChris Toshok <toshok@src.gnome.org>2000-09-01 17:05:56 +0800
commit943c181c658d64e2e89026db65613c905ffe9f25 (patch)
treee1acb10a097618e739915936e1315b9966d8ac38 /widgets/e-table/Makefile.am
parent0a380243b1363ab2477a8fd846d4fae92bb24912 (diff)
downloadgsoc2013-evolution-943c181c658d64e2e89026db65613c905ffe9f25.tar
gsoc2013-evolution-943c181c658d64e2e89026db65613c905ffe9f25.tar.gz
gsoc2013-evolution-943c181c658d64e2e89026db65613c905ffe9f25.tar.bz2
gsoc2013-evolution-943c181c658d64e2e89026db65613c905ffe9f25.tar.lz
gsoc2013-evolution-943c181c658d64e2e89026db65613c905ffe9f25.tar.xz
gsoc2013-evolution-943c181c658d64e2e89026db65613c905ffe9f25.tar.zst
gsoc2013-evolution-943c181c658d64e2e89026db65613c905ffe9f25.zip
new test, a home grown 2 hour hack of a file browser. uses
2000-09-01 Chris Toshok <toshok@helixcode.com> * e-tree-example-2.c: new test, a home grown 2 hour hack of a file browser. uses node_collapsed/emitted signals to populate the left tree. * Makefile.am: add tree-example-2.c stuff. * .cvsignore: add tree-example-2 svn path=/trunk/; revision=5163
Diffstat (limited to 'widgets/e-table/Makefile.am')
-rw-r--r--widgets/e-table/Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/widgets/e-table/Makefile.am b/widgets/e-table/Makefile.am
index 14bab7e2f4..1afe8d9f20 100644
--- a/widgets/e-table/Makefile.am
+++ b/widgets/e-table/Makefile.am
@@ -16,6 +16,7 @@ INCLUDES = \
$(GNOME_INCLUDEDIR) \
-DETABLE_GLADEDIR=\"$(gladedir)\" \
-I$(top_srcdir)/widgets/e-text \
+ -I$(top_srcdir)/widgets/e-paned \
-I$(top_srcdir)/e-util \
-I$(top_srcdir) \
-DG_LOG_DOMAIN=\"e-table\"
@@ -92,7 +93,7 @@ libetable_a_SOURCES = \
e-tree-simple.h
noinst_PROGRAMS = \
- table-test table-example-1 table-example-2 table-size-test tree-example-1
+ table-test table-example-1 table-example-2 table-size-test tree-example-1 tree-example-2
table_test_SOURCES = \
test-table.c \
@@ -163,6 +164,20 @@ tree_example_1_LDADD = \
$(top_builddir)/e-util/libeutil.la \
$(GNOME_PRINT_LIBS)
+tree_example_2_SOURCES = \
+ e-tree-example-2.c
+
+tree_example_2_LDFLAGS = `gnome-config --libs gdk_pixbuf` `gnome-config --libs vfs`
+
+tree_example_2_LDADD = \
+ libetable.a \
+ $(EXTRA_GNOME_LIBS) \
+ $(top_builddir)/widgets/e-text/libetext.a \
+ $(top_builddir)/widgets/e-paned/libepaned.a \
+ $(top_builddir)/widgets/misc/libemiscwidgets.a \
+ $(top_builddir)/e-util/libeutil.la \
+ $(GNOME_PRINT_LIBS)
+
icons = \
arrow-down.xpm \
arrow-up.xpm \