aboutsummaryrefslogtreecommitdiffstats
path: root/widgets/e-table/Makefile.am
diff options
context:
space:
mode:
authorChristopher James Lahey <clahey@helixcode.com>2000-06-11 05:16:45 +0800
committerChris Lahey <clahey@src.gnome.org>2000-06-11 05:16:45 +0800
commitc57de49bb5d65df1fa0d63285b296397be3af6f8 (patch)
treeb3812be586e590ebe6de41ac2739bde89c1d29b2 /widgets/e-table/Makefile.am
parent5dc1015e9666ef59682c46e306ed3a4add0a9356 (diff)
downloadgsoc2013-evolution-c57de49bb5d65df1fa0d63285b296397be3af6f8.tar
gsoc2013-evolution-c57de49bb5d65df1fa0d63285b296397be3af6f8.tar.gz
gsoc2013-evolution-c57de49bb5d65df1fa0d63285b296397be3af6f8.tar.bz2
gsoc2013-evolution-c57de49bb5d65df1fa0d63285b296397be3af6f8.tar.lz
gsoc2013-evolution-c57de49bb5d65df1fa0d63285b296397be3af6f8.tar.xz
gsoc2013-evolution-c57de49bb5d65df1fa0d63285b296397be3af6f8.tar.zst
gsoc2013-evolution-c57de49bb5d65df1fa0d63285b296397be3af6f8.zip
Added $(GNOME_PRINT_LIBS) to all of the LDADDs.
2000-06-10 Christopher James Lahey <clahey@helixcode.com> * Makefile.am: Added $(GNOME_PRINT_LIBS) to all of the LDADDs. * e-cell-text.c: Added printing of text cells. * e-cell.c, e-cell.h: Added print and print_height methods. * e-table-field-chooser.glade: Added a minimum size. * e-table-group-container.c: Fixed a rectangle sizing bug. * e-table-group-leaf.c: Implemented get_printable. * e-table-group.c, e-table-group.h: Added a get_printable method to return an EPrintable. * e-table-item.c, e-table-item.h: Added a get_printable function to return an EPrintable. * e-table.c, e-table.h: Added a get_printable function to return an EPrintable. svn path=/trunk/; revision=3511
Diffstat (limited to 'widgets/e-table/Makefile.am')
-rw-r--r--widgets/e-table/Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/widgets/e-table/Makefile.am b/widgets/e-table/Makefile.am
index 8048435753..5f7af50a9a 100644
--- a/widgets/e-table/Makefile.am
+++ b/widgets/e-table/Makefile.am
@@ -12,6 +12,7 @@ glade_headers = \
INCLUDES = \
$(EXTRA_GNOME_CFLAGS) \
+ $(GNOME_PRINT_CFLAGS) \
$(GNOME_INCLUDEDIR) \
-DETABLE_GLADEDIR=\"$(gladedir)\" \
-I$(top_srcdir)/widgets/e-text \
@@ -94,7 +95,8 @@ table_test_LDADD = \
libetable.a \
$(EXTRA_GNOME_LIBS) \
$(top_builddir)/widgets/e-text/libetext.a \
- $(top_builddir)/e-util/libeutil.la
+ $(top_builddir)/e-util/libeutil.la \
+ $(GNOME_PRINT_LIBS)
table_test_LDFLAGS = `gnome-config --libs gdk_pixbuf`
@@ -105,7 +107,8 @@ table_size_test_LDADD = \
libetable.a \
$(EXTRA_GNOME_LIBS) \
$(top_builddir)/widgets/e-text/libetext.a \
- $(top_builddir)/e-util/libeutil.la
+ $(top_builddir)/e-util/libeutil.la \
+ $(GNOME_PRINT_LIBS)
table_size_test_LDFLAGS = `gnome-config --libs gdk_pixbuf`
@@ -116,7 +119,8 @@ table_example_1_LDADD = \
libetable.a \
$(EXTRA_GNOME_LIBS) \
$(top_builddir)/widgets/e-text/libetext.a \
- $(top_builddir)/e-util/libeutil.la
+ $(top_builddir)/e-util/libeutil.la \
+ $(GNOME_PRINT_LIBS)
table_example_1_LDFLAGS = `gnome-config --libs gdk_pixbuf`
@@ -127,7 +131,8 @@ table_example_2_LDADD = \
libetable.a \
$(EXTRA_GNOME_LIBS) \
$(top_builddir)/widgets/e-text/libetext.a \
- $(top_builddir)/e-util/libeutil.la
+ $(top_builddir)/e-util/libeutil.la \
+ $(GNOME_PRINT_LIBS)
table_example_2_LDFLAGS = `gnome-config --libs gdk_pixbuf`
@@ -140,7 +145,8 @@ tree_example_1_LDADD = \
libetable.a \
$(EXTRA_GNOME_LIBS) \
$(top_builddir)/widgets/e-text/libetext.a \
- $(top_builddir)/e-util/libeutil.la
+ $(top_builddir)/e-util/libeutil.la \
+ $(GNOME_PRINT_LIBS)
icons = \
arrow-down.xpm \