aboutsummaryrefslogtreecommitdiffstats
path: root/widgets/e-table/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@helixcode.com>2000-06-09 07:16:22 +0800
committerChris Toshok <toshok@src.gnome.org>2000-06-09 07:16:22 +0800
commite581631a9ce0803ba629ac67cd8934a6e23753ae (patch)
tree16fd9ebf869dd9fd82d265ce5a60a4ea7aeba652 /widgets/e-table/Makefile.am
parentf856d999c5cade657d045ea22b1fb64be481829d (diff)
downloadgsoc2013-evolution-e581631a9ce0803ba629ac67cd8934a6e23753ae.tar
gsoc2013-evolution-e581631a9ce0803ba629ac67cd8934a6e23753ae.tar.gz
gsoc2013-evolution-e581631a9ce0803ba629ac67cd8934a6e23753ae.tar.bz2
gsoc2013-evolution-e581631a9ce0803ba629ac67cd8934a6e23753ae.tar.lz
gsoc2013-evolution-e581631a9ce0803ba629ac67cd8934a6e23753ae.tar.xz
gsoc2013-evolution-e581631a9ce0803ba629ac67cd8934a6e23753ae.tar.zst
gsoc2013-evolution-e581631a9ce0803ba629ac67cd8934a6e23753ae.zip
New files. A tree model using a GNode structure to store it's info.
2000-06-08 Chris Toshok <toshok@helixcode.com> * e-tree-gnode.c, e-tree-gnode.h: New files. A tree model using a GNode structure to store it's info. * e-tree-model.c, e-tree-model.h: New files. A proxy model sitting between a table model and the real tree model (of which ETreeGNode is an example). * e-cell-tree.c, e-cell-tree.h: New files. A cell renderer capable of wrapping up a subcell and drawing the tree controls for expanding/collapsing trees. * tree-expanded.xpm, tree-unexpanded.xpm: New files. the standard + and - icons. * e-tree-example-1.c: New file, giving a (pretty poor :) example of using ETreeGNode. * Makefile.am: at the tree stuff to the build, and build tree-example-1. * .cvsignore: ignore tree-example-1. svn path=/trunk/; revision=3483
Diffstat (limited to 'widgets/e-table/Makefile.am')
-rw-r--r--widgets/e-table/Makefile.am21
1 files changed, 19 insertions, 2 deletions
diff --git a/widgets/e-table/Makefile.am b/widgets/e-table/Makefile.am
index bb0cc97edb..8048435753 100644
--- a/widgets/e-table/Makefile.am
+++ b/widgets/e-table/Makefile.am
@@ -31,6 +31,8 @@ libetable_a_SOURCES = \
e-cell-text.h \
e-cell-toggle.c \
e-cell-toggle.h \
+ e-cell-tree.c \
+ e-cell-tree.h \
e-table.c \
e-table.h \
e-table-col-dnd.h \
@@ -72,10 +74,14 @@ libetable_a_SOURCES = \
e-table-subset-variable.c \
e-table-subset-variable.h \
e-table-text-model.c \
- e-table-text-model.h
+ e-table-text-model.h \
+ e-tree-gnode.c \
+ e-tree-gnode.h \
+ e-tree-model.c \
+ e-tree-model.h
noinst_PROGRAMS = \
- table-test table-example-1 table-example-2 table-size-test
+ table-test table-example-1 table-example-2 table-size-test tree-example-1
table_test_SOURCES = \
test-table.c \
@@ -125,6 +131,17 @@ table_example_2_LDADD = \
table_example_2_LDFLAGS = `gnome-config --libs gdk_pixbuf`
+tree_example_1_SOURCES = \
+ e-tree-example-1.c
+
+tree_example_1_LDFLAGS = `gnome-config --libs gdk_pixbuf`
+
+tree_example_1_LDADD = \
+ libetable.a \
+ $(EXTRA_GNOME_LIBS) \
+ $(top_builddir)/widgets/e-text/libetext.a \
+ $(top_builddir)/e-util/libeutil.la
+
icons = \
arrow-down.xpm \
arrow-up.xpm \