aboutsummaryrefslogtreecommitdiffstats
path: root/widgets/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>1999-11-06 07:06:09 +0800
committerEttore Perazzoli <ettore@src.gnome.org>1999-11-06 07:06:09 +0800
commitb681ec2b9a98684ef821f9b6fbdb9a231a58d4b5 (patch)
tree6dc964528b9db296aa1dfedde9a2b2122fd0db8e /widgets/Makefile.am
parentc8fce201dc8b14505f2e0387689947922e08f956 (diff)
downloadgsoc2013-evolution-b681ec2b9a98684ef821f9b6fbdb9a231a58d4b5.tar
gsoc2013-evolution-b681ec2b9a98684ef821f9b6fbdb9a231a58d4b5.tar.gz
gsoc2013-evolution-b681ec2b9a98684ef821f9b6fbdb9a231a58d4b5.tar.bz2
gsoc2013-evolution-b681ec2b9a98684ef821f9b6fbdb9a231a58d4b5.tar.lz
gsoc2013-evolution-b681ec2b9a98684ef821f9b6fbdb9a231a58d4b5.tar.xz
gsoc2013-evolution-b681ec2b9a98684ef821f9b6fbdb9a231a58d4b5.tar.zst
gsoc2013-evolution-b681ec2b9a98684ef821f9b6fbdb9a231a58d4b5.zip
Here is my initial Evolution work: message composition widget and some
installation fixes for Camel. svn path=/trunk/; revision=1369
Diffstat (limited to 'widgets/Makefile.am')
-rw-r--r--widgets/Makefile.am36
1 files changed, 29 insertions, 7 deletions
diff --git a/widgets/Makefile.am b/widgets/Makefile.am
index d6aa94fb90..35d1bc64a4 100644
--- a/widgets/Makefile.am
+++ b/widgets/Makefile.am
@@ -1,7 +1,29 @@
-noinst_LIBRARIES = \
- e-table-simple.c \
- e-table-simple.h \
- e-table-model.c \
- e-table-model.h \
- e-table-column-model.c \
- e-table-column-model.h \
+guidir = $(datadir)/evolution/gui
+
+gui_DATA = \
+ e-msg-composer-attachment.glade \
+ e-msg-composer.glade
+
+INCLUDES = \
+ -I$(top_srcdir)/camel \
+ -I$(top_builddir)/camel \
+ $(GNOME_INCLUDEDIR)
+
+CPPFLAGS = \
+ -DE_GUIDIR=\"$(guidir)\"
+
+noinst_LTLIBRARIES = \
+ libevolutionwidgets.la
+
+libevolutionwidgets_la_SOURCES = \
+ e-msg-composer-address-entry.c \
+ e-msg-composer-address-entry.h \
+ e-msg-composer-attachment-bar.c \
+ e-msg-composer-attachment-bar.h \
+ e-msg-composer-attachment.c \
+ e-msg-composer-attachment.h \
+ e-msg-composer-hdrs.c \
+ e-msg-composer-hdrs.h \
+ e-msg-composer.c \
+ e-msg-composer.h
+