aboutsummaryrefslogtreecommitdiffstats
path: root/widgets/Makefile.am
diff options
context:
space:
mode:
authorChris Lahey <clahey@src.gnome.org>2000-01-14 06:01:23 +0800
committerChris Lahey <clahey@src.gnome.org>2000-01-14 06:01:23 +0800
commitf5347f59ff008ebc53f456cfcd4b8c58dead29c5 (patch)
tree1bfa9616fde11bbc40d7bf80557caf8f0429a84c /widgets/Makefile.am
parent21c698ec023314751227247e4bef1d68a78a21ea (diff)
downloadgsoc2013-evolution-f5347f59ff008ebc53f456cfcd4b8c58dead29c5.tar
gsoc2013-evolution-f5347f59ff008ebc53f456cfcd4b8c58dead29c5.tar.gz
gsoc2013-evolution-f5347f59ff008ebc53f456cfcd4b8c58dead29c5.tar.bz2
gsoc2013-evolution-f5347f59ff008ebc53f456cfcd4b8c58dead29c5.tar.lz
gsoc2013-evolution-f5347f59ff008ebc53f456cfcd4b8c58dead29c5.tar.xz
gsoc2013-evolution-f5347f59ff008ebc53f456cfcd4b8c58dead29c5.tar.zst
gsoc2013-evolution-f5347f59ff008ebc53f456cfcd4b8c58dead29c5.zip
e_canvas_item_move_absolute is just a helper function not supplied by the
* widgets/e-canvas-utils.c, widgets/e-canvas-utils.h: e_canvas_item_move_absolute is just a helper function not supplied by the gnome_canvas.[ch] I put it here so that multiple items can use it. * widgets/e-reflow.c, widgets/e-reflow.h: This item contains a number of other items and places them into multiple columns. The items contained must support a number of arguments and signals to allow the reflow to interact with them. * widgets/test-reflow.c: This is a test program for e-reflow. * widgets/e-text.c, widgets/e-text.h: Added properly drawn selected text. Added some preliminary code for X selection handling and cut & paste. * widgets/e-minicard.c, widgets/e-minicard.h: Added ARG_HAS_FOCUS handling. Made label display random for more interesting tests of multiple cards. Tweaked sizing information for better display. * widgets/e-minicard-label.c, widgets/e-minicard-label.h: Added ARG_HAS_FOCUS handling. * widgets/Makefile.am: Added the reflow test and reflow files. svn path=/trunk/; revision=1566
Diffstat (limited to 'widgets/Makefile.am')
-rw-r--r--widgets/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/widgets/Makefile.am b/widgets/Makefile.am
index 91e97910a7..1e2016ef3c 100644
--- a/widgets/Makefile.am
+++ b/widgets/Makefile.am
@@ -11,12 +11,16 @@ noinst_LIBRARIES = \
libevolutionwidgets.a
libevolutionwidgets_a_SOURCES = \
+ e-canvas-utils.c \
+ e-canvas-utils.h \
e-cursors.c \
e-cursors.h \
e-minicard.c \
e-minicard.h \
e-minicard-label.c \
e-minicard-label.h \
+ e-reflow.c \
+ e-reflow.h \
e-text.c \
e-text.h \
e-text-event-processor.c \
@@ -26,7 +30,8 @@ libevolutionwidgets_a_SOURCES = \
noinst_PROGRAMS = \
minicard-label-test \
- minicard-test
+ minicard-test \
+ reflow-test
minicard_label_test_SOURCES = \
test-minicard-label.c
@@ -41,3 +46,10 @@ minicard_test_SOURCES = \
minicard_test_LDADD = \
$(EXTRA_GNOME_LIBS) \
libevolutionwidgets.a
+
+reflow_test_SOURCES = \
+ test-reflow.c
+
+reflow_test_LDADD = \
+ $(EXTRA_GNOME_LIBS) \
+ libevolutionwidgets.a