aboutsummaryrefslogtreecommitdiffstats
path: root/widgets/Makefile.am
diff options
context:
space:
mode:
authorChris Lahey <clahey@src.gnome.org>2000-01-11 14:44:57 +0800
committerChris Lahey <clahey@src.gnome.org>2000-01-11 14:44:57 +0800
commita01de808cd46baea31419a42b221cb65974a9fb1 (patch)
treea32c6dc47d19d64c907d7d577798cad380a6caa2 /widgets/Makefile.am
parentb2a25c6add10c40eb6d369fdf504f2e7d13d2c97 (diff)
downloadgsoc2013-evolution-a01de808cd46baea31419a42b221cb65974a9fb1.tar
gsoc2013-evolution-a01de808cd46baea31419a42b221cb65974a9fb1.tar.gz
gsoc2013-evolution-a01de808cd46baea31419a42b221cb65974a9fb1.tar.bz2
gsoc2013-evolution-a01de808cd46baea31419a42b221cb65974a9fb1.tar.lz
gsoc2013-evolution-a01de808cd46baea31419a42b221cb65974a9fb1.tar.xz
gsoc2013-evolution-a01de808cd46baea31419a42b221cb65974a9fb1.tar.zst
gsoc2013-evolution-a01de808cd46baea31419a42b221cb65974a9fb1.zip
Removed some code which got in the way of testing properly.
* widgets/test-minicard.c: Removed some code which got in the way of testing properly. * widgets/e-minicard-label.c (e_minicard_label_realize): Made the field text item editable. * widgets/Makefile.am: Added e-text-event-process*.[ch]. * widgets/e-text.c, widgets/e-text.h: Changed these to support editing. * widgets/e-text-event-processor.c, widgets/e-text-event-processor.h, widgets/e-text-event-processor-types.h, widgets/e-text-event-processor-emacs-like.c, widgets/e-text-event-processor-emacs-like.h: These are a new pair of classes which handle all events from the text item and convert them into commands. svn path=/trunk/; revision=1553
Diffstat (limited to 'widgets/Makefile.am')
-rw-r--r--widgets/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/widgets/Makefile.am b/widgets/Makefile.am
index 76337f05a4..2012b00429 100644
--- a/widgets/Makefile.am
+++ b/widgets/Makefile.am
@@ -18,7 +18,11 @@ libevolutionwidgets_a_SOURCES = \
e-minicard-label.c \
e-minicard-label.h \
e-text.c \
- e-text.h
+ e-text.h \
+ e-text-event-processor.c \
+ e-text-event-processor.h \
+ e-text-event-processor-emacs-like.c \
+ e-text-event-processor-emacs-like.h
noinst_PROGRAMS = \
minicard-label-test \