aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2003-04-08 00:06:50 +0800
committerDan Winship <danw@src.gnome.org>2003-04-08 00:06:50 +0800
commit49eb4eb0e49f99762537e5d4337f06f90db084a2 (patch)
treeb09437b83a0e3a1dd7e4918c482974b17bc359ed /tools/Makefile.am
parent091e937669ab19e779ff3e2ef143722c93e41b79 (diff)
downloadgsoc2013-evolution-49eb4eb0e49f99762537e5d4337f06f90db084a2.tar
gsoc2013-evolution-49eb4eb0e49f99762537e5d4337f06f90db084a2.tar.gz
gsoc2013-evolution-49eb4eb0e49f99762537e5d4337f06f90db084a2.tar.bz2
gsoc2013-evolution-49eb4eb0e49f99762537e5d4337f06f90db084a2.tar.lz
gsoc2013-evolution-49eb4eb0e49f99762537e5d4337f06f90db084a2.tar.xz
gsoc2013-evolution-49eb4eb0e49f99762537e5d4337f06f90db084a2.tar.zst
gsoc2013-evolution-49eb4eb0e49f99762537e5d4337f06f90db084a2.zip
Install these in privlibexecdir, not privdatadir. Move killev from SCRIPTS
* tools/Makefile.am (privlibexec_SCRIPTS, privlibexec_PROGRAMS): Install these in privlibexecdir, not privdatadir. Move killev from SCRIPTS to PROGRAMS. (killev_SOURCES, killev_LDADD): Add * tools/killev.c: New C port of killev, since "bonobo-activation-query" does not return as much information as "oaf-client" did. Also has prettier output. (Still shells out to killall/pkill to do the actual killing.) * tools/killev: Gone * tools/evolution-move-tasks: Removed since the evolution-calendar code that called it is also gone now. svn path=/trunk/; revision=20700
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am28
1 files changed, 16 insertions, 12 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 5687cc174b..eb8ba15f25 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1,15 +1,13 @@
-toolsdir = $(privdatadir)/tools
-
-tools_SCRIPTS = \
+privlibexec_SCRIPTS = \
csv2vcard \
- evolution-move-tasks \
- evolution-addressbook-clean \
- killev
+ evolution-addressbook-clean
-tools_PROGRAMS = \
+privlibexec_PROGRAMS = \
evolution-addressbook-import \
evolution-addressbook-export \
- evolution-launch-composer
+ evolution-launch-composer \
+ killev
+
noinst_PROGRAMS = evolution-addressbook-abuse
@@ -56,8 +54,8 @@ evolution_addressbook_export_LDADD = \
evolution_addressbook_abuse_LDADD = \
$(evolution_addressbook_import_LDADD)
-evolution_launch_composer_SOURCES = \
- $(CORBA_SOURCE) \
+evolution_launch_composer_SOURCES = \
+ $(CORBA_SOURCE) \
evolution-launch-composer.c
evolution_launch_composer_LDADD = \
@@ -65,11 +63,17 @@ evolution_launch_composer_LDADD = \
$(top_builddir)/addressbook/backend/ebook/libebook.la \
$(top_builddir)/widgets/menus/libmenus.la
-CLEANFILES = evolution-addressbook-clean $(BUILD_SOURCES)
+killev_SOURCES = \
+ killev.c
+
+killev_LDADD = \
+ $(top_builddir)/e-util/libeutil.la
+
+CLEANFILES = evolution-addressbook-clean $(BUILT_SOURCES)
evolution-addressbook-clean: evolution-addressbook-clean.in Makefile
## Use sed and then mv to avoid problems if the user interrupts.
- sed -e 's?\@EVOLUTION_TOOLSDIR\@?$(toolsdir)?g' \
+ sed -e 's?\@EVOLUTION_TOOLSDIR\@?$(privlibexecdir)?g' \
< $(srcdir)/evolution-addressbook-clean.in > evolution-addressbook-clean.tmp \
&& mv evolution-addressbook-clean.tmp evolution-addressbook-clean