aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2003-02-28 15:48:26 +0800
committerChris Toshok <toshok@src.gnome.org>2003-02-28 15:48:26 +0800
commitdf08abfd54dfe76e57eb9b8fd10593d2e43d41ab (patch)
tree78f596e2137e6e1a3d0a5eaadff16d57f1c47fda /tools/Makefile.am
parentc003d7dec88fe3360b7a210bb2fcfa093eed5c56 (diff)
downloadgsoc2013-evolution-df08abfd54dfe76e57eb9b8fd10593d2e43d41ab.tar
gsoc2013-evolution-df08abfd54dfe76e57eb9b8fd10593d2e43d41ab.tar.gz
gsoc2013-evolution-df08abfd54dfe76e57eb9b8fd10593d2e43d41ab.tar.bz2
gsoc2013-evolution-df08abfd54dfe76e57eb9b8fd10593d2e43d41ab.tar.lz
gsoc2013-evolution-df08abfd54dfe76e57eb9b8fd10593d2e43d41ab.tar.xz
gsoc2013-evolution-df08abfd54dfe76e57eb9b8fd10593d2e43d41ab.tar.zst
gsoc2013-evolution-df08abfd54dfe76e57eb9b8fd10593d2e43d41ab.zip
ignore some stuff, yo.
2003-02-27 Chris Toshok <toshok@ximian.com> * tools/.cvsignore: ignore some stuff, yo. * tools/Makefile.am: add in the evolution-launch-composer stuff. * tools/evolution-launch-composer.c: port this from the 1.2 branch. svn path=/trunk/; revision=20098
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am32
1 files changed, 30 insertions, 2 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index dd73df96f6..06820ca533 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -8,7 +8,8 @@ tools_SCRIPTS = \
tools_PROGRAMS = \
evolution-addressbook-import \
- evolution-addressbook-export
+ evolution-addressbook-export \
+ evolution-launch-composer
noinst_PROGRAMS = evolution-addressbook-abuse
@@ -30,6 +31,20 @@ INCLUDES = \
EXTRA_DIST = $(tools_SCRIPTS) verify-evolution-install.sh \
evolution-addressbook-clean.in
+CORBA_SOURCE = \
+ Evolution-Composer.h \
+ Evolution-Composer-common.c \
+ Evolution-Composer-skels.c \
+ Evolution-Composer-stubs.c
+
+BUILT_SOURCES = $(CORBA_SOURCE)
+
+idls = \
+ $(top_srcdir)/composer/Evolution-Composer.idl
+
+$(CORBA_SOURCE): $(idls)
+ $(ORBIT_IDL) -I $(srcdir) $(IDL_INCLUDES) $(idls)
+
evolution_addressbook_import_LDADD = \
$(GNOME_FULL_LIBS) \
$(top_builddir)/addressbook/backend/ebook/libebook.la \
@@ -41,7 +56,20 @@ evolution_addressbook_export_LDADD = \
evolution_addressbook_abuse_LDADD = \
$(evolution_addressbook_import_LDADD)
-CLEANFILES = evolution-addressbook-clean
+evolution_launch_composer_SOURCES = \
+ $(CORBA_SOURCE) \
+ evolution-launch-composer.c
+
+evolution_launch_composer_LDADD = \
+ $(GNOME_FULL_LIBS) \
+ $(top_builddir)/addressbook/backend/ebook/libebook.la \
+ $(top_builddir)/camel/libcamel.la \
+ $(top_builddir)/e-util/ename/libename.la \
+ $(top_builddir)/libversit/libversit.a \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/widgets/menus/libmenus.la
+
+CLEANFILES = evolution-addressbook-clean $(BUILD_SOURCES)
evolution-addressbook-clean: evolution-addressbook-clean.in Makefile