aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorChristopher James Lahey <clahey@ximian.com>2001-10-19 05:18:25 +0800
committerChris Lahey <clahey@src.gnome.org>2001-10-19 05:18:25 +0800
commitd4fd9c55c7f5d5b7ad3f0bf1c4a2481023f7bceb (patch)
tree0345248e002c380e1eff080933d05ca7353118d4 /tools/Makefile.am
parent8589cb087050e616facdba00e79479868b08c07f (diff)
downloadgsoc2013-evolution-d4fd9c55c7f5d5b7ad3f0bf1c4a2481023f7bceb.tar
gsoc2013-evolution-d4fd9c55c7f5d5b7ad3f0bf1c4a2481023f7bceb.tar.gz
gsoc2013-evolution-d4fd9c55c7f5d5b7ad3f0bf1c4a2481023f7bceb.tar.bz2
gsoc2013-evolution-d4fd9c55c7f5d5b7ad3f0bf1c4a2481023f7bceb.tar.lz
gsoc2013-evolution-d4fd9c55c7f5d5b7ad3f0bf1c4a2481023f7bceb.tar.xz
gsoc2013-evolution-d4fd9c55c7f5d5b7ad3f0bf1c4a2481023f7bceb.tar.zst
gsoc2013-evolution-d4fd9c55c7f5d5b7ad3f0bf1c4a2481023f7bceb.zip
Bumped the required version of gal to 0.15.99.1 for use in
2001-10-18 Christopher James Lahey <clahey@ximian.com> * configure.in: Bumped the required version of gal to 0.15.99.1 for use in evolution-addressbook-export. * tools/.cvsignore: Added evolution-addressbook-clean, evolution-addressbook-export, evolution-addressbook-import, and .libs. * tools/Makefile.am: Added evolution-addressbook-clean, evolution-addressbook-export, and evolution-addressbook-import. * tools/evolution-addressbook-clean.in: Main script to clean up the local contact database. * tools/evolution-addressbook-export.c: Exports the local addressbook to the specified file (--output-file). If no --output-file is given, writes out to a unique file in the /tmp directory. In either case, prints the filename to stdout. * tools/evolution-addressbook-import.c: Imports the specified file (--input-file) to the local addressbook. svn path=/trunk/; revision=13774
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am41
1 files changed, 40 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index cd69457f3e..4b5516d28f 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1,3 +1,42 @@
-bin_SCRIPTS = killev evolution-move-tasks
+bin_SCRIPTS = killev evolution-move-tasks evolution-addressbook-clean
+bin_PROGRAMS = evolution-addressbook-import evolution-addressbook-export
+
+EXTRA_DIST = \
+ evolution-addressbook-clean.in
+
+INCLUDES = \
+ -DG_LOG_DOMAIN=\"evolution-tools\" \
+ $(EXTRA_GNOME_CFLAGS) \
+ $(GNOME_INCLUDEDIR) \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(BONOBO_HTML_GNOME_CFLAGS) \
+ -DEVOLUTION_BINDIR=\""$(bindir)"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -I$(top_srcdir)/addressbook
EXTRA_DIST = $(bin_SCRIPTS) verify-evolution-install.sh
+
+evolution_addressbook_import_LDADD = \
+ $(EXTRA_GNOME_LIBS) \
+ $(BONOBO_HTML_GNOME_LIBS) \
+ $(BONOBO_CONF_LIBS) \
+ $(top_builddir)/addressbook/backend/ebook/libebook.la \
+ $(top_builddir)/camel/libcamel.la \
+ $(top_builddir)/libibex/libibex.la \
+ $(top_builddir)/e-util/ename/libename.la \
+ $(top_builddir)/libversit/libversit.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/widgets/menus/libmenus.la
+
+evolution_addressbook_export_LDADD = \
+ $(evolution_addressbook_import_LDADD)
+
+CLEANFILES = evolution-addressbook-clean
+
+
+evolution-addressbook-clean: evolution-addressbook-clean.in Makefile
+## Use sed and then mv to avoid problems if the user interrupts.
+ sed -e 's?\@EVOLUTION_BINDIR\@?$(bindir)?g' \
+ < $(srcdir)/evolution-addressbook-clean.in > evolution-addressbook-clean.tmp \
+ && mv evolution-addressbook-clean.tmp evolution-addressbook-clean