aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2003-01-28 02:54:56 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2003-01-28 02:54:56 +0800
commit1d9a3023e59067ea10eea867cbcb831ea265beb3 (patch)
treea3ab6977f8d22c7afd83748371660f8feeedbf6d /tools/Makefile.am
parent6b1b5d30fd4dd6e02513947a1d706554ff2a9fec (diff)
downloadgsoc2013-evolution-1d9a3023e59067ea10eea867cbcb831ea265beb3.tar
gsoc2013-evolution-1d9a3023e59067ea10eea867cbcb831ea265beb3.tar.gz
gsoc2013-evolution-1d9a3023e59067ea10eea867cbcb831ea265beb3.tar.bz2
gsoc2013-evolution-1d9a3023e59067ea10eea867cbcb831ea265beb3.tar.lz
gsoc2013-evolution-1d9a3023e59067ea10eea867cbcb831ea265beb3.tar.xz
gsoc2013-evolution-1d9a3023e59067ea10eea867cbcb831ea265beb3.tar.zst
gsoc2013-evolution-1d9a3023e59067ea10eea867cbcb831ea265beb3.zip
#include bonobo-activation instead of oaf. (main): Initialize using
* tools/evolution-addressbook-export.c: #include bonobo-activation instead of oaf. (main): Initialize using gnome_program_init(). (save_cards): Use g_main_loop_quit() instead of gtk_exit(). * tools/evolution-addressbook-import.c: Update include list for GNOME 2. (main): Initialize using gnome_program_init(). (unref_executable): Use g_main_loop_quit() instead of gtk_exit(). (add_cb): Likewise. * tools/evolution-addressbook-abuse.c: Update include list for GNOME 2. (main): Initialize using gnome_program_init(). (use_addressbook): Use g_object_unref() instead of gtk_object_unref(). (main): Use g_timeout_add() instead of gtk_timeout_add(). (add_cb): Use g_main_loop_quit() instead of gtk_exit(). * configure.in (AC_SUBST): Add tools/Makefile. * Makefile.am (SUBDIRS): Add tools/ back into the list. * tools/Makefile.am: Install everything in $(datadir)/evolution-$(BASE_VERSION)/tools. (INCLUDES): Add the defines that gnome_program_init() likes and also add the _DISABLE_DEPRECATED stuff. svn path=/trunk/; revision=19656
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index a2de0296a6..4a2b484a9b 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1,10 +1,12 @@
-bin_SCRIPTS = \
+toolsdir = $(datadir)/evolution-$(BASE_VERSION)/tools
+
+tools_SCRIPTS = \
csv2vcard \
evolution-move-tasks \
evolution-addressbook-clean \
killev
-bin_PROGRAMS = \
+tools_PROGRAMS = \
evolution-addressbook-import \
evolution-addressbook-export
@@ -16,9 +18,14 @@ INCLUDES = \
-I$(top_builddir) \
-DEVOLUTION_BINDIR=\""$(bindir)"\" \
-DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DPREFIX=\""$(prefix)"\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
-I$(top_srcdir)/addressbook \
-I$(top_srcdir)/addressbook/backend \
-I$(top_builddir)/addressbook/backend \
+ -DG_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED \
$(GNOME_FULL_CFLAGS)
EXTRA_DIST = $(bin_SCRIPTS) verify-evolution-install.sh \