aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorbertrand <Bertrand.Guiheneuf@aful.org>2000-02-11 08:43:23 +0800
committerBertrand Guiheneuf <bertrand@src.gnome.org>2000-02-11 08:43:23 +0800
commit784c1184a8d73c23f6462997da00e354297fdf78 (patch)
treee4a1e5d7c64da8b50fe58926d334604a1bc9b329 /tests/Makefile.am
parent11a8bba27ea6fd7dc37b478be03831ddc561f28a (diff)
downloadgsoc2013-evolution-784c1184a8d73c23f6462997da00e354297fdf78.tar
gsoc2013-evolution-784c1184a8d73c23f6462997da00e354297fdf78.tar.gz
gsoc2013-evolution-784c1184a8d73c23f6462997da00e354297fdf78.tar.bz2
gsoc2013-evolution-784c1184a8d73c23f6462997da00e354297fdf78.tar.lz
gsoc2013-evolution-784c1184a8d73c23f6462997da00e354297fdf78.tar.xz
gsoc2013-evolution-784c1184a8d73c23f6462997da00e354297fdf78.tar.zst
gsoc2013-evolution-784c1184a8d73c23f6462997da00e354297fdf78.zip
don't build thread related tests if evolution has been compiled with no
2000-02-10 bertrand <Bertrand.Guiheneuf@aful.org> * tests/Makefile.am (THREAD_RELATED_TESTS): don't build thread related tests if evolution has been compiled with no thread support. * configure.in (have_pthread): allow user to enable/disable thread support at configure time (EXTRA_GNOME_CFLAGS): (EXTRA_GNOME_LIBS): thread support is directly included in this variable if enabled. No more EXTRA_GNOME_CFLAGS_THREADS Other special support should be added in EXTRA_GNOME_LIBS and EXTRA_GNOME_CFLAGS instead of redefining a new variable each time we want to add a new lib. (bonobo, ....) * camel/camel.c (camel_init): only try to initialize threads if we enabled threads support. * tests/ui-tests/Makefile.am (message_browser_LDADD): use EXTRA_GNOME_LIBS * configure.in (have_pthread): remove HAVE_PTHREADS variable. Define ENABLE_THREADS instead. * camel/Makefile.am: use ENABLE_THREADS not HAVE_PTHREADS to test if we build thread relateed code. * tests/Makefile.am: use EXTRA_GNOME_LIBS, not EXTRA_GNOME_LIBS_THREADS I need to be able to disable thread support to use Insure. svn path=/trunk/; revision=1725
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7f5873ea53..441837288d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -6,7 +6,7 @@ INCLUDES = -I$(top_srcdir)/intl -I$(top_srcdir) -I$(top_srcdir)/camel \
LDADD = \
$(top_builddir)/camel/libcamel.la \
$(GNOME_LIBDIR) \
- $(GNOMEUI_LIBS) $(INTLLIBS) $(PTHREAD_LIB) $(EXTRA_GNOME_LIBS_THREADS)
+ $(GNOMEUI_LIBS) $(INTLLIBS) $(EXTRA_GNOME_LIBS)
# $(BONOBO_LIBS)
@@ -22,7 +22,13 @@ test9_LDADD = \
$(top_builddir)/camel/libcamel.la \
$(top_builddir)/camel/providers/mbox/libcamelmbox.la \
$(GNOME_LIBDIR) \
- $(GNOMEUI_LIBS) $(INTLLIBS) $(PTHREAD_LIB) $(EXTRA_GNOME_LIBS_THREADS)
+ $(GNOMEUI_LIBS) $(INTLLIBS) $(EXTRA_GNOME_LIBS)
+
+if ENABLE_THREADS
+THREAD_RELATED_TESTS=test8
+else
+THREAD_RELATED_TESTS=
+endif
noinst_PROGRAMS = \
@@ -30,7 +36,7 @@ noinst_PROGRAMS = \
test2 \
test3 \
test7 \
- test8 \
test9 \
test10 \
- test-formatter
+ test-formatter \
+ $(THREAD_RELATED_TESTS)