aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorbertrand <bertrand@helixcode.com>2000-01-17 16:40:11 +0800
committerBertrand Guiheneuf <bertrand@src.gnome.org>2000-01-17 16:40:11 +0800
commit3bdd857a4a69e83841c2fbae83d96101912ebf69 (patch)
tree96287828f9f04604e529a52b11a0f07206d04744 /tests/Makefile.am
parent8c55e9f58b86483aa64c75a9324cd04e3ae79b2b (diff)
downloadgsoc2013-evolution-3bdd857a4a69e83841c2fbae83d96101912ebf69.tar
gsoc2013-evolution-3bdd857a4a69e83841c2fbae83d96101912ebf69.tar.gz
gsoc2013-evolution-3bdd857a4a69e83841c2fbae83d96101912ebf69.tar.bz2
gsoc2013-evolution-3bdd857a4a69e83841c2fbae83d96101912ebf69.tar.lz
gsoc2013-evolution-3bdd857a4a69e83841c2fbae83d96101912ebf69.tar.xz
gsoc2013-evolution-3bdd857a4a69e83841c2fbae83d96101912ebf69.tar.zst
gsoc2013-evolution-3bdd857a4a69e83841c2fbae83d96101912ebf69.zip
test for the mbox utils. (copy_file_chunk): fixed a nasty bug.
2000-01-17 bertrand <bertrand@helixcode.com> * tests/test9.c (main): test for the mbox utils. (copy_file_chunk): fixed a nasty bug. (camel_mbox_write_xev): create the copy file descriptor with the proper arguments. Exceptions implememnted. (camel_mbox_write_xev): changed the way bytes are counted. No more uses the message size cause it did not take into account the message separators characters. (camel_mbox_write_xev): hopefully fixed the last bugs. works ok now. Summary information / X-Evolution header generation should all work ok now. svn path=/trunk/; revision=1579
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 432c39a953..a7f0cb1883 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,7 +1,8 @@
# process this file with automake to create Makefile.in
INCLUDES = -I$(top_srcdir)/intl -I$(top_srcdir) -I$(top_srcdir)/camel \
- -I$(includedir) -I$(top_srcdir)/camel/providers/MH
+ -I$(includedir) -I$(top_srcdir)/camel/providers/MH \
+ -I$(top_srcdir)/camel/providers/mbox
LDADD = \
$(top_builddir)/camel/libcamel.la \
$(GNOME_LIBDIR) \
@@ -17,10 +18,17 @@ LDADD = \
# $(GNOME_LIBDIR) \
# $(GNOMEUI_LIBS) $(INTLLIBS) $(PTHREAD_LIB)
+test9_LDADD = \
+ $(top_builddir)/camel/libcamel.la \
+ $(top_builddir)/camel/providers/mbox/libcamelmbox.la \
+ $(GNOME_LIBDIR) \
+ $(GNOMEUI_LIBS) $(INTLLIBS) $(PTHREAD_LIB) $(EXTRA_GNOME_LIBS_THREADS)
+
noinst_PROGRAMS = \
test1 \
test2 \
test3 \
test7 \
- test8
+ test8 \
+ test9