aboutsummaryrefslogtreecommitdiffstats
path: root/smime/lib/Makefile.am
diff options
context:
space:
mode:
authorMilan Crha <mcrha@redhat.com>2014-03-25 19:04:58 +0800
committerMilan Crha <mcrha@redhat.com>2014-03-25 19:04:58 +0800
commit8692b1cb72654888f0dab31843bdf05d3ac2a888 (patch)
tree3e172e8085830cf0770cf0a7ab04bd714753d3a9 /smime/lib/Makefile.am
parent399b1a6fc593a9c5e692923120346e0386f578e5 (diff)
downloadgsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.gz
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.bz2
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.lz
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.xz
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.tar.zst
gsoc2013-evolution-8692b1cb72654888f0dab31843bdf05d3ac2a888.zip
Add an --enable-code-coverage configure option to enable gcov support
When enabled, this will compile all libraries/binaries with the necessary gcc and ld flags to enable code coverage support using gcov.
Diffstat (limited to 'smime/lib/Makefile.am')
-rw-r--r--smime/lib/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/smime/lib/Makefile.am b/smime/lib/Makefile.am
index 0bb36ce11f..811c77831e 100644
--- a/smime/lib/Makefile.am
+++ b/smime/lib/Makefile.am
@@ -15,7 +15,8 @@ libessmime_la_CPPFLAGS = \
$(EVOLUTION_DATA_SERVER_CFLAGS) \
$(GNOME_PLATFORM_CFLAGS) \
$(GTKHTML_CFLAGS) \
- $(CERT_UI_CFLAGS)
+ $(CERT_UI_CFLAGS) \
+ $(CODE_COVERAGE_CFLAGS)
libessmime_la_SOURCES = \
e-cert.c \
@@ -34,6 +35,6 @@ libessmime_la_LIBADD = \
$(GTKHTML_LIBS) \
$(CERT_UI_LIBS)
-libessmime_la_LDFLAGS = -avoid-version $(NO_UNDEFINED)
+libessmime_la_LDFLAGS = -avoid-version $(NO_UNDEFINED) $(CODE_COVERAGE_LDFLAGS)
-include $(top_srcdir)/git.mk