aboutsummaryrefslogtreecommitdiffstats
path: root/smclient/Makefile.am
diff options
context:
space:
mode:
authorH.Habighorst <h.habighorst@googlemail.com>2009-10-01 11:37:50 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-10-01 11:37:50 +0800
commitf62728b55e201ea92e682e07b3253ce4fb42d5af (patch)
tree2083db9702cd5068e7fc4471c47086071e366015 /smclient/Makefile.am
parentda3ae4fd5fa723abc4574d0459c761e76abba080 (diff)
downloadgsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.gz
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.bz2
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.lz
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.xz
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.tar.zst
gsoc2013-evolution-f62728b55e201ea92e682e07b3253ce4fb42d5af.zip
Bug 596848 - Use per-target CPPFLAGS in automake files
Diffstat (limited to 'smclient/Makefile.am')
-rw-r--r--smclient/Makefile.am17
1 files changed, 12 insertions, 5 deletions
diff --git a/smclient/Makefile.am b/smclient/Makefile.am
index 4d5c63f0fc..cbc004fa36 100644
--- a/smclient/Makefile.am
+++ b/smclient/Makefile.am
@@ -8,15 +8,16 @@ platform_libs = libeggdesktopfile.la -lSM -lICE
platform_sources = eggsmclient-xsmp.c
endif
-AM_CPPFLAGS = \
- -DG_LOG_DOMAIN=\""EggSMClient"\" \
- $(platform_defines) \
- $(EGG_SMCLIENT_CFLAGS)
-
noinst_LTLIBRARIES = \
libeggsmclient.la \
$(platform_ltlibraries)
+libeggsmclient_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -DG_LOG_DOMAIN=\""EggSMClient"\" \
+ $(platform_defines) \
+ $(EGG_SMCLIENT_CFLAGS)
+
libeggsmclient_la_LIBADD = \
$(EGG_SMCLIENT_LIBS) \
$(platform_libs)
@@ -30,6 +31,12 @@ libeggsmclient_la_SOURCES = \
eggsmclient-private.h \
$(platform_sources)
+libeggdesktopfile_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -DG_LOG_DOMAIN=\""EggSMClient"\" \
+ $(platform_defines) \
+ $(EGG_SMCLIENT_CFLAGS)
+
libeggdesktopfile_la_LIBADD = \
$(EGG_SMCLIENT_LIBS)