aboutsummaryrefslogtreecommitdiffstats
path: root/smclient/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2009-07-11 06:36:49 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-07-11 06:47:29 +0800
commit10eab2350036e1c36377c93d31472125b3e7c8c7 (patch)
tree5e33457567b4fddf2f7cd6b795d0ca6e13624099 /smclient/Makefile.am
parent6e7f42e0a60659411f2e10dbf8e84c705f0498a4 (diff)
downloadgsoc2013-evolution-10eab2350036e1c36377c93d31472125b3e7c8c7.tar
gsoc2013-evolution-10eab2350036e1c36377c93d31472125b3e7c8c7.tar.gz
gsoc2013-evolution-10eab2350036e1c36377c93d31472125b3e7c8c7.tar.bz2
gsoc2013-evolution-10eab2350036e1c36377c93d31472125b3e7c8c7.tar.lz
gsoc2013-evolution-10eab2350036e1c36377c93d31472125b3e7c8c7.tar.xz
gsoc2013-evolution-10eab2350036e1c36377c93d31472125b3e7c8c7.tar.zst
gsoc2013-evolution-10eab2350036e1c36377c93d31472125b3e7c8c7.zip
Implement the shutdown protocol and stub in session management.
The shutdown protocol is modelled after online/offline preparation. Session management code is copied from libegg. Not yet used.
Diffstat (limited to 'smclient/Makefile.am')
-rw-r--r--smclient/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/smclient/Makefile.am b/smclient/Makefile.am
new file mode 100644
index 0000000000..53cb8f684f
--- /dev/null
+++ b/smclient/Makefile.am
@@ -0,0 +1,45 @@
+if OS_WIN32
+platform_sources = eggsmclient-win32.c
+platform_logout_test_ldflags = -mwindows
+else
+platform_defines = -DEGG_SM_CLIENT_BACKEND_XSMP
+platform_ltlibraries = libeggdesktopfile.la
+platform_libs = libeggdesktopfile.la -lSM -lICE
+platform_sources = eggsmclient-xsmp.c
+endif
+
+AM_CPPFLAGS = \
+ -DG_LOG_DOMAIN=\""EggSMClient"\" \
+ $(platform_defines) \
+ $(EGG_SMCLIENT_CFLAGS)
+
+noinst_LTLIBRARIES = \
+ libeggsmclient.la \
+ $(platform_ltlibraries)
+
+libeggsmclient_la_LIBADD = \
+ $(EGG_SMCLIENT_LIBS) \
+ $(platform_libs)
+
+libeggsmclient_la_LDFLAGS = \
+ $(platform_ldflags)
+
+libeggsmclient_la_SOURCES = \
+ eggsmclient.c \
+ eggsmclient.h \
+ eggsmclient-private.h \
+ $(platform_sources)
+
+libeggdesktopfile_la_LIBADD = \
+ $(EGG_SMCLIENT_LIBS)
+
+libeggdesktopfile_la_SOURCES = \
+ eggdesktopfile.c \
+ eggdesktopfile.h
+
+EXTRA_DIST = \
+ eggsmclient-osx.c \
+ eggsmclient-win32.c \
+ eggsmclient-xsmp.c
+
+-include $(top_srcdir)/git.mk