aboutsummaryrefslogtreecommitdiffstats
path: root/smclient/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2012-10-16 21:04:21 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-10-16 21:38:21 +0800
commit4afc8d39bf9371d4e76eae54e5b8d825366476b7 (patch)
tree907e81320fc8161caec2b9732f6d2763bc735925 /smclient/Makefile.am
parenta902cc15ed320d304de306a0f63db127d41e3e18 (diff)
downloadgsoc2013-evolution-4afc8d39bf9371d4e76eae54e5b8d825366476b7.tar
gsoc2013-evolution-4afc8d39bf9371d4e76eae54e5b8d825366476b7.tar.gz
gsoc2013-evolution-4afc8d39bf9371d4e76eae54e5b8d825366476b7.tar.bz2
gsoc2013-evolution-4afc8d39bf9371d4e76eae54e5b8d825366476b7.tar.lz
gsoc2013-evolution-4afc8d39bf9371d4e76eae54e5b8d825366476b7.tar.xz
gsoc2013-evolution-4afc8d39bf9371d4e76eae54e5b8d825366476b7.tar.zst
gsoc2013-evolution-4afc8d39bf9371d4e76eae54e5b8d825366476b7.zip
Bug 676141 - Use GtkApplication for session management
As of GTK+ 3.4, GtkApplication now provides session management support similar to EggSMClient. So drop our copy of EggSMClient.
Diffstat (limited to 'smclient/Makefile.am')
-rw-r--r--smclient/Makefile.am50
1 files changed, 0 insertions, 50 deletions
diff --git a/smclient/Makefile.am b/smclient/Makefile.am
deleted file mode 100644
index 775eee085c..0000000000
--- a/smclient/Makefile.am
+++ /dev/null
@@ -1,50 +0,0 @@
-if OS_WIN32
-platform_sources = eggsmclient-win32.c
-platform_logout_test_ldflags = -mwindows
-else
-platform_defines = -DEGG_SM_CLIENT_BACKEND_XSMP
-platform_ltlibraries = libeggdesktopfile.la
-platform_libs = libeggdesktopfile.la -lSM -lICE
-platform_sources = eggsmclient-xsmp.c
-endif
-
-noinst_LTLIBRARIES = \
- libeggsmclient.la \
- $(platform_ltlibraries)
-
-libeggsmclient_la_CPPFLAGS = \
- $(AM_CPPFLAGS) \
- -DG_LOG_DOMAIN=\""EggSMClient"\" \
- $(platform_defines) \
- $(EGG_SMCLIENT_CFLAGS)
-
-libeggsmclient_la_LIBADD = \
- $(EGG_SMCLIENT_LIBS) \
- $(platform_libs)
-
-libeggsmclient_la_LDFLAGS = -avoid-version $(platform_ldflags)
-
-libeggsmclient_la_SOURCES = \
- eggsmclient.c \
- eggsmclient.h \
- eggsmclient-private.h \
- $(platform_sources)
-
-libeggdesktopfile_la_CPPFLAGS = \
- $(AM_CPPFLAGS) \
- -DG_LOG_DOMAIN=\""EggSMClient"\" \
- $(platform_defines) \
- $(EGG_SMCLIENT_CFLAGS)
-
-libeggdesktopfile_la_LIBADD = \
- $(EGG_SMCLIENT_LIBS)
-
-libeggdesktopfile_la_SOURCES = \
- eggdesktopfile.c \
- eggdesktopfile.h
-
-EXTRA_DIST = \
- eggsmclient-win32.c \
- eggsmclient-xsmp.c
-
--include $(top_srcdir)/git.mk