aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2000-06-10 03:19:36 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2000-06-10 03:19:36 +0800
commit7f36752a67c274640378ec096f37e690fd5ca8ed (patch)
treedcc3124da275074dcf11803bb553d2af384858db /shell/Makefile.am
parent59d329b5b090175e2ea5ffd06cb20dfcd41a7688 (diff)
downloadgsoc2013-evolution-7f36752a67c274640378ec096f37e690fd5ca8ed.tar
gsoc2013-evolution-7f36752a67c274640378ec096f37e690fd5ca8ed.tar.gz
gsoc2013-evolution-7f36752a67c274640378ec096f37e690fd5ca8ed.tar.bz2
gsoc2013-evolution-7f36752a67c274640378ec096f37e690fd5ca8ed.tar.lz
gsoc2013-evolution-7f36752a67c274640378ec096f37e690fd5ca8ed.tar.xz
gsoc2013-evolution-7f36752a67c274640378ec096f37e690fd5ca8ed.tar.zst
gsoc2013-evolution-7f36752a67c274640378ec096f37e690fd5ca8ed.zip
Initial support for creating/removing folders. This implies some new
IDL methods and new functions to implement on the component side. I have also added a simple folder creation dialog in the shell. It's quite unfinished and untested. svn path=/trunk/; revision=3491
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am95
1 files changed, 52 insertions, 43 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 6141f9ce69..7788803994 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -1,3 +1,5 @@
+SUBDIRS = glade
+
imagesdir = $(datadir)/images/evolution
bin_PROGRAMS = evolution
@@ -27,49 +29,56 @@ IDLS = \
Evolution-ShellComponent.idl \
Evolution-Storage.idl
-evolution_SOURCES = \
- $(EVOLUTION_CORBA_GENERATED) \
- e-corba-storage.c \
- e-corba-storage.h \
- e-corba-storage-registry.c \
- e-corba-storage-registry.h \
- e-folder-type-registry.c \
- e-folder-type-registry.h \
- e-folder.c \
- e-folder.h \
- e-local-folder.c \
- e-local-folder.h \
- e-local-storage.c \
- e-local-storage.h \
- e-setup.c \
- e-setup.h \
- e-component-registry.h \
- e-component-registry.c \
- e-shell-constants.h \
- e-shell-folder-title-bar.c \
- e-shell-folder-title-bar.h \
- e-shell-utils.c \
- e-shell-utils.h \
- e-shell-view-menu.c \
- e-shell-view-menu.h \
- e-shell-view.c \
- e-shell-view.h \
- e-shell.c \
- e-shell.h \
- e-shortcuts-view.c \
- e-shortcuts-view.h \
- e-shortcuts.c \
- e-shortcuts.h \
- e-storage-set-view.c \
- e-storage-set-view.h \
- e-storage-set.c \
- e-storage-set.h \
- e-storage.c \
- e-storage.h \
- evolution-shell-component.c \
- evolution-shell-component.h \
- evolution-storage.c \
- evolution-storage.h \
+CPPFLAGS = \
+ -DE_GLADEDIR=\"$(datadir)/evolution/glade\"
+
+evolution_SOURCES = \
+ $(EVOLUTION_CORBA_GENERATED) \
+ e-component-registry.c \
+ e-component-registry.h \
+ e-corba-storage-registry.c \
+ e-corba-storage-registry.h \
+ e-corba-storage.c \
+ e-corba-storage.h \
+ e-folder-type-registry.c \
+ e-folder-type-registry.h \
+ e-folder.c \
+ e-folder.h \
+ e-local-folder.c \
+ e-local-folder.h \
+ e-local-storage.c \
+ e-local-storage.h \
+ e-setup.c \
+ e-setup.h \
+ e-shell-constants.h \
+ e-shell-folder-creation-dialog.c \
+ e-shell-folder-creation-dialog.h \
+ e-shell-folder-title-bar.c \
+ e-shell-folder-title-bar.h \
+ e-shell-utils.c \
+ e-shell-utils.h \
+ e-shell-view-menu.c \
+ e-shell-view-menu.h \
+ e-shell-view.c \
+ e-shell-view.h \
+ e-shell.c \
+ e-shell.h \
+ e-shortcuts-view.c \
+ e-shortcuts-view.h \
+ e-shortcuts.c \
+ e-shortcuts.h \
+ e-storage-set-view.c \
+ e-storage-set-view.h \
+ e-storage-set.c \
+ e-storage-set.h \
+ e-storage.c \
+ e-storage.h \
+ evolution-shell-component-client.c \
+ evolution-shell-component-client.h \
+ evolution-shell-component.c \
+ evolution-shell-component.h \
+ evolution-storage.c \
+ evolution-storage.h \
main.c
Evolution-impl.o: Evolution.h