aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2001-06-24 21:13:50 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2001-06-24 21:13:50 +0800
commitea40bb0823d313579eb992f441d6fd08f7ef23a7 (patch)
tree36eaa395508d25f0c8ae26d56ed0ddf44f40793d /shell/Makefile.am
parent5b52672a1524bd6fda554c2abab496f856a5bbee (diff)
downloadgsoc2013-evolution-ea40bb0823d313579eb992f441d6fd08f7ef23a7.tar
gsoc2013-evolution-ea40bb0823d313579eb992f441d6fd08f7ef23a7.tar.gz
gsoc2013-evolution-ea40bb0823d313579eb992f441d6fd08f7ef23a7.tar.bz2
gsoc2013-evolution-ea40bb0823d313579eb992f441d6fd08f7ef23a7.tar.lz
gsoc2013-evolution-ea40bb0823d313579eb992f441d6fd08f7ef23a7.tar.xz
gsoc2013-evolution-ea40bb0823d313579eb992f441d6fd08f7ef23a7.tar.zst
gsoc2013-evolution-ea40bb0823d313579eb992f441d6fd08f7ef23a7.zip
Added an EvolutionActivityClient object to libeshell, to handle
updating of progress information from the component's side. This object allows to automatically set a lower limit to the delay between CORBA calls towards the shell, so that the component isn't slowed down too much by doing too frequent updates. Also changed the test component to use this instead of doing CORBA calls directly. svn path=/trunk/; revision=10449
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 08c24b5268..d2d7438035 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -57,6 +57,7 @@ eshellincludedir = $(includedir)/evolution/shell
eshellinclude_HEADERS = \
Evolution.h \
e-folder-tree.h \
+ evolution-activity-client.h \
evolution-local-storage.h \
evolution-session.h \
evolution-shell-client.h \
@@ -72,6 +73,7 @@ eshellinclude_HEADERS = \
libeshell_la_SOURCES = \
$(IDL_GENERATED) \
e-folder-tree.c \
+ evolution-activity-client.c \
evolution-local-storage.c \
evolution-session.c \
evolution-shell-client.c \