aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2009-11-27 10:16:40 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-11-27 10:18:59 +0800
commitc6727d66ade72df6fbaff9f111a06993aeefdecc (patch)
tree85f609c96e7606251b26f46e1b64ddb47ce4a61e /shell/Makefile.am
parent4837f2a2530c35c8f7076817e1341ddcf05b4ef7 (diff)
downloadgsoc2013-evolution-c6727d66ade72df6fbaff9f111a06993aeefdecc.tar
gsoc2013-evolution-c6727d66ade72df6fbaff9f111a06993aeefdecc.tar.gz
gsoc2013-evolution-c6727d66ade72df6fbaff9f111a06993aeefdecc.tar.bz2
gsoc2013-evolution-c6727d66ade72df6fbaff9f111a06993aeefdecc.tar.lz
gsoc2013-evolution-c6727d66ade72df6fbaff9f111a06993aeefdecc.tar.xz
gsoc2013-evolution-c6727d66ade72df6fbaff9f111a06993aeefdecc.tar.zst
gsoc2013-evolution-c6727d66ade72df6fbaff9f111a06993aeefdecc.zip
Implement a new 'killev' program.
For now this only terminates Evolution, but the same basic approach should also be used with the Evolution-Data-Server D-Bus services.
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 541f941e58..6ff40baab7 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -114,12 +114,12 @@ evolution_CPPFLAGS = \
-DEVOLUTION_ICONDIR=\""$(icondir)"\" \
-DEVOLUTION_MODULEDIR=\""$(moduledir)"\" \
-DEVOLUTION_RULEDIR=\""$(privdatadir)"\" \
+ -DEVOLUTION_TOOLSDIR=\""$(privlibexecdir)"\" \
-DEVOLUTION_UIDIR=\""$(uidir)"\" \
-DPREFIX=\""$(prefix)"\" \
-DSYSCONFDIR=\""$(sysconfdir)"\" \
-DDATADIR=\""$(datadir)"\" \
-DLIBDIR=\""$(datadir)"\" \
- -DG_LOG_DOMAIN=\"evolution-shell\" \
$(TZDIALOG_CFLAGS) \
$(SHELL_CFLAGS)
@@ -142,6 +142,22 @@ if OS_WIN32
evolution_LDFLAGS = -mwindows
endif
+# Killev utility
+
+if OS_WIN32
+else
+privlibexec_PROGRAMS = killev
+endif
+
+killev_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ $(GNOME_PLATFORM_CFLAGS)
+
+killev_SOURCES = killev.c
+
+killev_LDADD = $(GNOME_PLATFORM_LIBS)
+
# Misc stuff
error_DATA = shell.error