aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2001-08-10 07:37:56 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2001-08-10 07:37:56 +0800
commit20801a94aaba0002a8adb7df3829494e4164d5bf (patch)
treea13690465e7f5eeb434f4bb1104ec3e9fc1670ae /shell/Makefile.am
parent3c88c8b755113fb61bf153d6070ed92274fb5d02 (diff)
downloadgsoc2013-evolution-20801a94aaba0002a8adb7df3829494e4164d5bf.tar
gsoc2013-evolution-20801a94aaba0002a8adb7df3829494e4164d5bf.tar.gz
gsoc2013-evolution-20801a94aaba0002a8adb7df3829494e4164d5bf.tar.bz2
gsoc2013-evolution-20801a94aaba0002a8adb7df3829494e4164d5bf.tar.lz
gsoc2013-evolution-20801a94aaba0002a8adb7df3829494e4164d5bf.tar.xz
gsoc2013-evolution-20801a94aaba0002a8adb7df3829494e4164d5bf.tar.zst
gsoc2013-evolution-20801a94aaba0002a8adb7df3829494e4164d5bf.zip
Add the menu items using the EShellUserCreatableItemsHandler.
* e-shell-view.c (e_shell_view_construct): Add the menu items using the EShellUserCreatableItemsHandler. * e-shell-user-creatable-items-handler.c: New. * e-shell-user-creatable-items-handler.h: New. * e-shell.c: New member `user_creatable_items_handler' in `EShellPrivate'. (init): Initialize to NULL. (destroy): Unref. (e_shell_construct): Create here. (e_shell_get_user_creatable_items_handler): New accessor. (setup_components): Add the registered components to the user_creatable_items_handler. * evolution-test-component.c (factory_fn): Add a couple sample user-creatable items. (user_create_new_item_callback): New callback for the "user_create_new_item" signal on the EvolutionShellComponent. (factory_fn): Connect. * e-shell.c (e_shell_get_component_registry): New. * evolution-shell-component.c: New enum value `USER_CREATE_NEW_ITEM'. New member `user_create_item_types' in `_EvolutionShellComponentPrivate'. (init): Init to NULL. (impl_destroy): Free it. (user_creatable_item_type_free): New helper function. (user_creatable_item_type_new): New helper function. (impl_userCreateNewItem): New, implementation for ::userCreateNewItem. (class_init): Install the "user_create_new_item" signal and the userCreateNewItem impl. (impl__get_external_uri_schemas): Renamed from `impl_ShellComponent__get_external_uri_schemas'. (impl___get_supported_types): Renamed from `impl_ShellComponent__get_supported_types'. (impl__get_user_creatable_item_types): New, implementation for the `user_creatable_item_types' attribute. (class_init): Install it. (evolution_shell_component_add_user_creatable_item): New. * evolution-shell-component.h: Added signal `user_create_new_item'. * Evolution-ShellComponent.idl: Added typedefs `UserCreatableItemType', `UserCreatableItemTypeList'. New attribute `user_creatable_item_types'. (userCreateNewItem): New. svn path=/trunk/; revision=11849
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 19fa11e45f..b5904ef965 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -125,6 +125,8 @@ evolution_SOURCES = \
e-shell-importer.h \
e-shell-offline-handler.c \
e-shell-offline-handler.h \
+ e-shell-user-creatable-items-handler.c \
+ e-shell-user-creatable-items-handler.h \
e-shell-utils.c \
e-shell-utils.h \
e-shell-view-menu.c \