aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2000-04-25 22:08:37 +0800
committerDan Winship <danw@src.gnome.org>2000-04-25 22:08:37 +0800
commit4c9ac5da23cc25f17eea7f43ba07bf858a80b2ee (patch)
treeda9751e02d8b44961ada85e448ac4bb941730310 /shell/Makefile.am
parent5f54bb7ea062c14e1f0bdf9778774c8c7f470be8 (diff)
downloadgsoc2013-evolution-4c9ac5da23cc25f17eea7f43ba07bf858a80b2ee.tar
gsoc2013-evolution-4c9ac5da23cc25f17eea7f43ba07bf858a80b2ee.tar.gz
gsoc2013-evolution-4c9ac5da23cc25f17eea7f43ba07bf858a80b2ee.tar.bz2
gsoc2013-evolution-4c9ac5da23cc25f17eea7f43ba07bf858a80b2ee.tar.lz
gsoc2013-evolution-4c9ac5da23cc25f17eea7f43ba07bf858a80b2ee.tar.xz
gsoc2013-evolution-4c9ac5da23cc25f17eea7f43ba07bf858a80b2ee.tar.zst
gsoc2013-evolution-4c9ac5da23cc25f17eea7f43ba07bf858a80b2ee.zip
include -I$(datadir)/idl in orbit-idl arguments so that you can have
* shell/Makefile.am: include -I$(datadir)/idl in orbit-idl arguments so that you can have bonobo installed in the same prefix as evolution, when that isn't the same prefix is gnome-libs, which a lot of people seem to be doing. (CLEANFILES): add EVOLUTION_CORBA_GENERATED * README: Note this svn path=/trunk/; revision=2599
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 6a5d1cbf7a..5bdbe11e14 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -16,6 +16,8 @@ EVOLUTION_CORBA_GENERATED = \
Evolution-skels.c \
Evolution-stubs.c
+CLEANFILES = $(EVOLUTION_CORBA_GENERATED)
+
evolution_SOURCES = \
$(EVOLUTION_CORBA_GENERATED) \
main.c \
@@ -42,7 +44,7 @@ evolution_SOURCES = \
Evolution-impl.o: Evolution.h
$(EVOLUTION_CORBA_GENERATED): Evolution.idl evolution-service-repository.idl
- orbit-idl -I`$(GNOME_CONFIG) --datadir`/idl -I$(srcdir) $(srcdir)/Evolution.idl
+ $(ORBIT_IDL) -I$(datadir)/idl -I`$(GNOME_CONFIG) --datadir`/idl -I$(srcdir) $(srcdir)/Evolution.idl
evolution_LDADD = \
../widgets/shortcut-bar/libshortcut-bar.a \