aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2000-10-02 22:22:11 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2000-10-02 22:22:11 +0800
commite062edf57318b368b82862dc40c17bcd4be86661 (patch)
tree0fed023afae4a59f56bca368b61ee8951ac05b01 /shell/Makefile.am
parent9f7278389604e1a8c212aac3056a122e99cf4344 (diff)
downloadgsoc2013-evolution-e062edf57318b368b82862dc40c17bcd4be86661.tar
gsoc2013-evolution-e062edf57318b368b82862dc40c17bcd4be86661.tar.gz
gsoc2013-evolution-e062edf57318b368b82862dc40c17bcd4be86661.tar.bz2
gsoc2013-evolution-e062edf57318b368b82862dc40c17bcd4be86661.tar.lz
gsoc2013-evolution-e062edf57318b368b82862dc40c17bcd4be86661.tar.xz
gsoc2013-evolution-e062edf57318b368b82862dc40c17bcd4be86661.tar.zst
gsoc2013-evolution-e062edf57318b368b82862dc40c17bcd4be86661.zip
Added the ability for the shell to export the storage set view as a
Bonobo::Control (untested, and needed by Toshok's subscription dialog). Also, added a custom interface for this control so that the container can get notification when a folder gets selected. svn path=/trunk/; revision=5657
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index f68b15bc75..9da449867b 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -20,13 +20,14 @@ CLEANFILES = $(IDL_GENERATED)
# CORBA stuff
IDLS = \
- Evolution.idl \
Evolution-LocalStorage.idl \
Evolution-Session.idl \
Evolution-Shell.idl \
Evolution-ShellComponent.idl \
Evolution-ShellView.idl \
- Evolution-Storage.idl
+ Evolution-Storage.idl \
+ Evolution-StorageSetView.idl \
+ Evolution.idl
IDL_GENERATED = \
Evolution.h \
@@ -114,6 +115,10 @@ evolution_SOURCES = \
e-storage-set.h \
e-storage.c \
e-storage.h \
+ evolution-storage-set-view.c \
+ evolution-storage-set-view.h \
+ evolution-storage-set-view-factory.c \
+ evolution-storage-set-view-factory.h \
main.c
evolution_LDADD = \