aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorArturo Espinosa <unammx@src.gnome.org>2000-01-12 12:25:38 +0800
committerArturo Espinosa <unammx@src.gnome.org>2000-01-12 12:25:38 +0800
commitc1209c281ed79b5dcc9c201f1968fba972c3641a (patch)
treef7ddae99a57045442873205a8088d5aa3f6cc9ea /shell/Makefile.am
parentf3c94fc0f415a4025add6debe451ca3e9e449d83 (diff)
downloadgsoc2013-evolution-c1209c281ed79b5dcc9c201f1968fba972c3641a.tar
gsoc2013-evolution-c1209c281ed79b5dcc9c201f1968fba972c3641a.tar.gz
gsoc2013-evolution-c1209c281ed79b5dcc9c201f1968fba972c3641a.tar.bz2
gsoc2013-evolution-c1209c281ed79b5dcc9c201f1968fba972c3641a.tar.lz
gsoc2013-evolution-c1209c281ed79b5dcc9c201f1968fba972c3641a.tar.xz
gsoc2013-evolution-c1209c281ed79b5dcc9c201f1968fba972c3641a.tar.zst
gsoc2013-evolution-c1209c281ed79b5dcc9c201f1968fba972c3641a.zip
More
More svn path=/trunk/; revision=1561
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 03848c6110..18e0cce064 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -9,6 +9,12 @@ INCLUDES = \
-I$(srcdir)/../widgets \
$(BONOBO_GNOME_CFLAGS)
+EVOLUTION_CORBA_GENERATED = \
+ Evolution.h \
+ Evolution-common.c \
+ Evolution-skels.c \
+ Evolution-stubs.c
+
evolution_SOURCES = \
main.c \
e-folder.c \
@@ -18,11 +24,21 @@ evolution_SOURCES = \
e-init.c \
e-init.h \
e-shell.c \
- e-shell.h
+ e-shell.h \
+ e-shell-view.c \
+ e-shell-view.h \
+ e-shell-view-menu.c \
+ e-shell-view-menu.h \
+ $(EVOLUTION_CORBA_GENERATED)
+
+Evolution-impl.o: Evolution.h
+$(EVOOLUTION_CORBA_GENERATED): Evolution.idl
+ orbit-idl -I`$(GNOME_CONFIG) --datadir`/idl -I$(srcdir) $(srcdir)/Evolution.idl
evolution_LDADD = \
../widgets/shortcut-bar/libshortcut-bar.a \
../e-util/libeutil.a \
$(BONOBO_GNOME_LIBS)
+EXTRA_DIST = Evolution.idl \ No newline at end of file