aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2000-05-07 09:57:49 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2000-05-07 09:57:49 +0800
commit725d0a088ddafd5f5665f4415c54f12411103e83 (patch)
tree5cf59c14ca05b80fa206bda3a6ee27a075f8ad22 /shell/Makefile.am
parentd92547ebaa21c0175f9cab9cb828d31d5896e5c5 (diff)
downloadgsoc2013-evolution-725d0a088ddafd5f5665f4415c54f12411103e83.tar
gsoc2013-evolution-725d0a088ddafd5f5665f4415c54f12411103e83.tar.gz
gsoc2013-evolution-725d0a088ddafd5f5665f4415c54f12411103e83.tar.bz2
gsoc2013-evolution-725d0a088ddafd5f5665f4415c54f12411103e83.tar.lz
gsoc2013-evolution-725d0a088ddafd5f5665f4415c54f12411103e83.tar.xz
gsoc2013-evolution-725d0a088ddafd5f5665f4415c54f12411103e83.tar.zst
gsoc2013-evolution-725d0a088ddafd5f5665f4415c54f12411103e83.zip
Big shell reorganization.
svn path=/trunk/; revision=2848
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am63
1 files changed, 41 insertions, 22 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index d7b69b32e5..f49b4a72e5 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -9,6 +9,7 @@ INCLUDES = \
-DEVOLUTION_IMAGES=\""$(imagesdir)"\" \
-DEVOLUTION_VERSION=\""$(VERSION)"\" \
-DEVOLUTION_LOCALEDIR=\""$(datadir)/locale"\" \
+ -DEVOLUTION_DATADIR=\""$(datadir)"\" \
-DG_LOG_DOMAIN=\"evolution-shell\"
EVOLUTION_CORBA_GENERATED = \
@@ -19,30 +20,37 @@ EVOLUTION_CORBA_GENERATED = \
CLEANFILES = $(EVOLUTION_CORBA_GENERATED)
-evolution_SOURCES = \
+evolution_SOURCES = \
$(EVOLUTION_CORBA_GENERATED) \
- main.c \
- e-folder.c \
- e-folder.h \
- e-init.c \
- e-init.h \
- e-shell.c \
- e-shell.h \
- e-shell-shortcut.c \
- e-shell-shortcut.h \
- e-shell-view.c \
- e-shell-view.h \
- e-shell-view-menu.c \
- e-shell-view-menu.h \
- e-shortcut.c \
- e-shortcut.h \
+ e-folder-type-repository.c \
+ e-folder-type-repository.h \
+ e-folder.c \
+ e-folder.h \
+ e-local-folder.c \
+ e-local-folder.h \
+ e-local-storage.c \
+ e-local-storage.h \
+ e-setup.c \
+ e-setup.h \
+ e-shell-view-menu.c \
+ e-shell-view-menu.h \
+ e-shell-view.c \
+ e-shell-view.h \
+ e-shell.c \
+ e-shell.h \
+ e-shortcuts-view.c \
+ e-shortcuts-view.h \
+ e-shortcuts.c \
+ e-shortcuts.h \
+ e-storage-set.c \
+ e-storage-set.h \
+ e-storage-watcher.c \
+ e-storage-watcher.h \
+ e-storage.c \
+ e-storage.h \
evolution-service-repository.c \
- evolution-service-repository.h
-
-Evolution-impl.o: Evolution.h
-
-$(EVOLUTION_CORBA_GENERATED): Evolution.idl evolution-service-repository.idl
- $(ORBIT_IDL) -I$(datadir)/idl -I`$(GNOME_CONFIG) --datadir`/idl -I$(srcdir) $(srcdir)/Evolution.idl
+ evolution-service-repository.h \
+ main.c
evolution_LDADD = \
../widgets/shortcut-bar/libshortcut-bar.a \
@@ -50,6 +58,17 @@ evolution_LDADD = \
../e-util/libeutil.la \
$(BONOBO_GNOME_LIBS)
+Evolution-impl.o: Evolution.h
+
+$(EVOLUTION_CORBA_GENERATED): Evolution.idl evolution-service-repository.idl
+ $(ORBIT_IDL) -I$(datadir)/idl -I`$(GNOME_CONFIG) --datadir`/idl -I$(srcdir) $(srcdir)/Evolution.idl
+
+evolution_LDADD = \
+ $(top_builddir)/widgets/shortcut-bar/libshortcut-bar.a \
+ $(top_builddir)/widgets/e-text/libetext.a \
+ $(top_builddir)/e-util/libeutil.la \
+ $(BONOBO_GNOME_LIBS)
+
EXTRA_DIST = Evolution.idl \
Shell.idl \
evolution-service-repository.idl