aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2002-11-18 19:29:35 +0800
committerMichael Zucci <zucchi@src.gnome.org>2002-11-18 19:29:35 +0800
commitabda9814844d31daaf4c6355da9a886c69bda9be (patch)
tree96d29ba229f701c22f6af2216cb1336d45b0c773 /shell/Makefile.am
parentbe05081ea93b28c601dcb62a5190200c995c9d4d (diff)
downloadgsoc2013-evolution-abda9814844d31daaf4c6355da9a886c69bda9be.tar
gsoc2013-evolution-abda9814844d31daaf4c6355da9a886c69bda9be.tar.gz
gsoc2013-evolution-abda9814844d31daaf4c6355da9a886c69bda9be.tar.bz2
gsoc2013-evolution-abda9814844d31daaf4c6355da9a886c69bda9be.tar.lz
gsoc2013-evolution-abda9814844d31daaf4c6355da9a886c69bda9be.tar.xz
gsoc2013-evolution-abda9814844d31daaf4c6355da9a886c69bda9be.tar.zst
gsoc2013-evolution-abda9814844d31daaf4c6355da9a886c69bda9be.zip
from clicked_cb. (start_import): gtkdialogise.
2002-11-18 Not Zed <NotZed@Ximian.com> * importer/importer.c (dialog_response_cb): from clicked_cb. (start_import): gtkdialogise. * e-shell-importer.c: removed redundant header. (create_html): Removed utf8 from locale stuff. (get_name_from_component_info): oaf->bonobo activation. (get_iid_for_filetype): " (create_plugin_menu): Likewise, and change oafiid to bonoboiid (get_intelligent_importers): " (prepare_intelligent_page): " (show_import_wizard): add null domain to glade_xml_new. (choose_importer_from_list): gtkdialogise. (dialog_response_cb): changed from dialog_clicked_cb. (start_import): gtkdialogise. (show_error): use gtk message box. (error_response_cb): callback to close error box. (show_import_wizard): gnome_druid_page_start/finish -> gnome_druid_page_edge. (prepare_file_page): (filename_changed): set HELP button insensitive. (create_plugin_menu): casts for warnings and fix a typo, set_data->set_data_full. (import_druid_finish): folder_selection_dialog api change(?), allow create. (dialog_weak_notify): renamed from close_dialog(). (show_import_wizard): remove gnome_dialog_close_hides -> its a gtkwindow anyway(!). * Makefile.am (evolution_LDADD): Added back importer. (evolution_SOURCES): Added back importer. * importer/intelligent.c (get_intelligent_importers): bonobo-activationised. (create_gui): gtkdialogise. (intelligent_importer_init): gtkdialogise. (create_gui): remove gnome_util_user_home(). (intelligent_importer_init): " * importer/evolution-importer.c (finalise): from destroy. (evolution_importer_new): type_new->object_new. * importer/evolution-importer-listener.c (finalise): from destroy. (evolution_importer_listener_new): type_new->object_new. * importer/evolution-importer-client.c (destroy): removed, as it wasn't used anyway. (evolution_importer_client_new): g_object_new. (finalise): added, tho doesn't do anythign yet, should it unref the client->objref? This whole class doesn't seem much use. * importer/evolution-importer-client.h: removed bonobo-object-client, change to g_object. * importer/*.[ch]: ran fix script over everything. * importer/evolution-intelligent-importer.c: gobjectise. (finalise): renamed from destroy. (evolution_intelligent_importer_new): gtk_type_new -> g_object_new svn path=/trunk/; revision=18821
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am14
1 files changed, 4 insertions, 10 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 838e582237..8e38448ad5 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -1,6 +1,4 @@
-SUBDIRS = glade
-
-# FIXME importer
+SUBDIRS = glade importer
INCLUDES = \
-I$(top_srcdir)/widgets \
@@ -177,6 +175,8 @@ evolution_SOURCES = \
e-shell-folder-selection-dialog.h \
e-shell-folder-title-bar.c \
e-shell-folder-title-bar.h \
+ e-shell-importer.c \
+ e-shell-importer.h \
e-shell-offline-handler.c \
e-shell-offline-handler.h \
e-shell-offline-sync.c \
@@ -225,15 +225,13 @@ evolution_SOURCES = \
evolution_LDADD = \
libeshell.la \
+ importer/libevolution-importer.la \
$(top_builddir)/widgets/e-timezone-dialog/libetimezonedialog.a \
$(top_builddir)/widgets/misc/libemiscwidgets.a \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/libical/src/libical/libical-evolution.la \
$(SHELL_LIBS)
-# FIXME
-# importer/libevolution-importer.la \
-
# Test component
noinst_PROGRAMS = \
@@ -323,7 +321,3 @@ if HAVE_DTAPPINTEGRATE
bin_SCRIPTS = evolution-nognome
endif
-
-# FIXME TODO:
-# e-shell-importer.c
-# e-shell-importer.h