aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorJP Rosevear <jpr@novell.com>2005-01-07 07:22:28 +0800
committerJP Rosevear <jpr@src.gnome.org>2005-01-07 07:22:28 +0800
commitefbf78e91db2d2a61a9bc1429fd10300fd8fd98d (patch)
tree69ad3e8a537c8a7b33cd1a041c47870e47da0607 /shell/Makefile.am
parent5effb957e90226a4c99e9f9bbbf6b27378d943c8 (diff)
downloadgsoc2013-evolution-efbf78e91db2d2a61a9bc1429fd10300fd8fd98d.tar
gsoc2013-evolution-efbf78e91db2d2a61a9bc1429fd10300fd8fd98d.tar.gz
gsoc2013-evolution-efbf78e91db2d2a61a9bc1429fd10300fd8fd98d.tar.bz2
gsoc2013-evolution-efbf78e91db2d2a61a9bc1429fd10300fd8fd98d.tar.lz
gsoc2013-evolution-efbf78e91db2d2a61a9bc1429fd10300fd8fd98d.tar.xz
gsoc2013-evolution-efbf78e91db2d2a61a9bc1429fd10300fd8fd98d.tar.zst
gsoc2013-evolution-efbf78e91db2d2a61a9bc1429fd10300fd8fd98d.zip
install schemas properly and add some uninstall rules for local install
2005-01-06 JP Rosevear <jpr@novell.com> * Makefile.am: install schemas properly and add some uninstall rules for local install rules svn path=/trunk/; revision=28257
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index bfaa6d97a5..849133aff9 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -200,7 +200,7 @@ schema_DATA = $(schema_in_files:.schemas.in.in=-$(BASE_VERSION).schemas)
install-data-local:
if test -z "$(DESTDIR)" ; then \
for p in $(schema_DATA) ; do \
- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p; \
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $$p; \
done \
fi
@@ -211,6 +211,12 @@ if DEFAULT_BINARY
cd $(DESTDIR)$(bindir) && rm -f evolution && $(LN_S) evolution-$(BASE_VERSION) evolution
endif
+uninstall-evolution:
+ $(LIBTOOL) --mode=uninstall rm -rf $(DESTDIR)$(bindir)/evolution-$(BASE_VERSION)
+if DEFAULT_BINARY
+ rm -f $(DESTDIR)$(bindir)/evolution
+endif
+
if HAVE_DTAPPINTEGRATE
install-exec-local: install-evolution
@@ -218,9 +224,13 @@ install-exec-local: install-evolution
mv $(DESTDIR)$(bindir)/evolution-$(BASE_VERSION) $(DESTDIR)$(libexecdir)/evolution-$(BASE_VERSION)
$(INSTALL_PROGRAM) evolution-nognome $(DESTDIR)$(bindir)/evolution-$(BASE_VERSION)
+uninstall-local: uninstall-evolution
+ rm -rf $(DESTDIR)$(libexecdir)/evolution-$(BASE_VERSION)
+ rm -rf $(DESTDIR)$(bindir)/evolution-$(BASE_VERSION)/evolution-nognome
else
install-exec-local: install-evolution
+uninstall-local: uninstall-evolution
endif