aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorPeter Williams <peterw@ximian.com>2001-05-26 12:59:00 +0800
committerPeter Williams <peterw@src.gnome.org>2001-05-26 12:59:00 +0800
commita58c7b50e9a4b2d03763eff154b47a47e3398d11 (patch)
tree213b3dde4689c5aa95a2ba7d14e7a66ba90de62d /shell/Makefile.am
parentc6c02db6022e3a702c096d3f7cbc34af8cf68342 (diff)
downloadgsoc2013-evolution-a58c7b50e9a4b2d03763eff154b47a47e3398d11.tar
gsoc2013-evolution-a58c7b50e9a4b2d03763eff154b47a47e3398d11.tar.gz
gsoc2013-evolution-a58c7b50e9a4b2d03763eff154b47a47e3398d11.tar.bz2
gsoc2013-evolution-a58c7b50e9a4b2d03763eff154b47a47e3398d11.tar.lz
gsoc2013-evolution-a58c7b50e9a4b2d03763eff154b47a47e3398d11.tar.xz
gsoc2013-evolution-a58c7b50e9a4b2d03763eff154b47a47e3398d11.tar.zst
gsoc2013-evolution-a58c7b50e9a4b2d03763eff154b47a47e3398d11.zip
Reference libeshell.la instead of libeshell.a.
2001-05-25 Peter Williams <peterw@ximian.com> * gui/component/Makefile.am: Reference libeshell.la instead of libeshell.a. 2001-05-25 Peter Williams <peterw@ximian.com> * gui/Makefile.am: Reference libeshell.la instead of libeshell.a. 2001-05-25 Peter Williams <peterw@ximian.com> * component/Makefile.am: Reference libeshell.la instead of libeshell.a. 2001-05-25 Peter Williams <peterw@ximian.com> * Makefile.am: Reference libeshell.la instead of libeshell.a. 2001-05-25 Peter Williams <peterw@ximian.com> * Makefile.am: Change libeshell from a noinst_LIBRARIES to a lib_LTLIBRARIES. Install its headers in $includedir/evolution/shell. * evolution-storage.c (safe_corba_string): New, copy of e_safe_corba_string in libeutil. This way libeshell doesn't have a missing symbol when programs that don't have libeutil link to it. (evolution_storage_register): s,e_safe_corba_string,safe_corba_string,g. svn path=/trunk/; revision=10007
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am36
1 files changed, 21 insertions, 15 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 8cd1c9c3ef..2b9ba7a20e 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -47,33 +47,39 @@ idl_DATA = $(IDLS)
# Shell library
-noinst_LIBRARIES = \
- libeshell.a
+lib_LTLIBRARIES = \
+ libeshell.la
-libeshell_a_SOURCES = \
+eshellincludedir = $(includedir)/evolution/shell
+
+eshellinclude_HEADERS = \
+ Evolution.h \
+ e-folder-tree.h \
+ evolution-local-storage.h \
+ evolution-session.h \
+ evolution-shell-client.h \
+ evolution-shell-component-client.h \
+ evolution-shell-component.h \
+ evolution-shell-component-dnd.h \
+ evolution-shell-view.h \
+ evolution-storage-listener.h \
+ evolution-storage-set-view-listener.h \
+ evolution-storage.h
+
+libeshell_la_SOURCES = \
$(IDL_GENERATED) \
e-folder-tree.c \
- e-folder-tree.h \
evolution-local-storage.c \
- evolution-local-storage.h \
evolution-session.c \
- evolution-session.h \
evolution-shell-client.c \
- evolution-shell-client.h \
evolution-shell-component-client.c \
- evolution-shell-component-client.h \
evolution-shell-component.c \
- evolution-shell-component.h \
evolution-shell-component-dnd.c \
- evolution-shell-component-dnd.h \
evolution-shell-view.c \
- evolution-shell-view.h \
evolution-storage-listener.c \
- evolution-storage-listener.h \
evolution-storage-set-view-listener.c \
- evolution-storage-set-view-listener.h \
evolution-storage.c \
- evolution-storage.h
+ $(eshellinclude_HEADERS)
# Evolution executable
@@ -138,7 +144,7 @@ evolution_SOURCES = \
main.c
evolution_LDADD = \
- libeshell.a \
+ libeshell.la \
importer/libevolution-importer.la \
$(top_builddir)/widgets/misc/libemiscwidgets.a \
$(top_builddir)/e-util/libeutil.la \