aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@src.gnome.org>2000-05-05 20:46:42 +0800
committerChris Toshok <toshok@src.gnome.org>2000-05-05 20:46:42 +0800
commitf80ee8128bb94839d8a84cc620a209d37bbfa277 (patch)
tree539f24780ebcc00aa42489ae534248d9d3975d6d /shell/Makefile.am
parent1b8139c995a32f7f6843d56146c040e4f6d697ea (diff)
downloadgsoc2013-evolution-f80ee8128bb94839d8a84cc620a209d37bbfa277.tar
gsoc2013-evolution-f80ee8128bb94839d8a84cc620a209d37bbfa277.tar.gz
gsoc2013-evolution-f80ee8128bb94839d8a84cc620a209d37bbfa277.tar.bz2
gsoc2013-evolution-f80ee8128bb94839d8a84cc620a209d37bbfa277.tar.lz
gsoc2013-evolution-f80ee8128bb94839d8a84cc620a209d37bbfa277.tar.xz
gsoc2013-evolution-f80ee8128bb94839d8a84cc620a209d37bbfa277.tar.zst
gsoc2013-evolution-f80ee8128bb94839d8a84cc620a209d37bbfa277.zip
add support for building purified evolution.
* shell/Makefile.am: add support for building purified evolution. * shell/.cvsignore: ignore evolution.pure svn path=/trunk/; revision=2813
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index a4d4776e76..d7b69b32e5 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -54,3 +54,13 @@ EXTRA_DIST = Evolution.idl \
Shell.idl \
evolution-service-repository.idl
+if ENABLE_PURIFY
+PLINK = $(LIBTOOL) --mode=link $(PURIFY) $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
+
+all-local: evolution.pure
+
+evolution.pure: evolution
+ @rm -f evolution.pure
+ $(PLINK) $(evolution_LDFLAGS) $(evolution_OBJECTS) $(evolution_LDADD) $(LIBS)
+
+endif