aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2003-12-02 10:17:34 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2003-12-02 10:17:34 +0800
commitac0442e31c68ce073e4156bbe47d63da8f7d2523 (patch)
tree937719987d7b438cd4db1b3f0326bde0a622e615 /shell/Makefile.am
parent9b2e5956080b08da3611996c7f12158fcfe3e06d (diff)
downloadgsoc2013-evolution-ac0442e31c68ce073e4156bbe47d63da8f7d2523.tar
gsoc2013-evolution-ac0442e31c68ce073e4156bbe47d63da8f7d2523.tar.gz
gsoc2013-evolution-ac0442e31c68ce073e4156bbe47d63da8f7d2523.tar.bz2
gsoc2013-evolution-ac0442e31c68ce073e4156bbe47d63da8f7d2523.tar.lz
gsoc2013-evolution-ac0442e31c68ce073e4156bbe47d63da8f7d2523.tar.xz
gsoc2013-evolution-ac0442e31c68ce073e4156bbe47d63da8f7d2523.tar.zst
gsoc2013-evolution-ac0442e31c68ce073e4156bbe47d63da8f7d2523.zip
Pass a label for the status bar control for now.
* gui/component/addressbook-component.c (impl_createControls): Pass a label for the status bar control for now. * gui/calendar-component.c (impl_createControls): Pass a label for the status bar control for now. * gui/tasks-component.c (impl_createControls): Pass a label for the status bar control for now. * mail-component.c (impl_createControls): Pass a label for the status bar control for now. * e-shell.c (struct _EShellPrivate): Remove member activity_handler. (setup_activity_interface): Remove. (e_shell_init): Don't call. (create_window): Don't attach the task bar to the activity handler. * e-shell-window.c (struct _ComponentView): New member statusbar_widget. (struct _EShellWindowPrivate): Remove member task_bar. (init_view): Get the status bar control from createControls and put it in the ComponentView struct. (setup_task_bar): New. (setup_statusbar_notebook): New. (switch_view): Switch the statusbar notebook too. (impl_dispose): Add missing GTK_OBJECT() cast. (e_shell_window_peek_task_bar): Remove. * Evolution-Component.idl (Component::createControls): New out arg "statusbar_control"; this way components can provide their own status bar. * e-activity-handler.c, e-activity-handler.h: Turn into a plain GObject; translate all the CORBA methods into plain C methods. * Makefile.am: Move e-activity-handler to libeshell instead of it being in the shell. svn path=/trunk/; revision=23555
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 7dc9e7e896..8ac0866d88 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -109,6 +109,7 @@ eshellincludedir = $(privincludedir)/shell
eshellinclude_HEADERS = \
Evolution.h \
+ e-activity-handler.h \
e-folder-list.h \
e-folder-tree.h \
e-folder.h \
@@ -129,6 +130,7 @@ eshellinclude_HEADERS = \
libeshell_la_SOURCES = \
$(IDL_GENERATED) \
$(MARSHAL_GENERATED) \
+ e-activity-handler.c \
e-folder-list.c \
e-folder-tree.c \
e-folder.c \
@@ -155,8 +157,6 @@ libeshell_la_LIBADD = \
evolution_SOURCES = \
$(SELECT_NAMES_IDL_GENERATED) \
$(DATASERVER_IDL_GENERATED) \
- e-activity-handler.c \
- e-activity-handler.h \
e-component-registry.c \
e-component-registry.h \
e-config-upgrade.c \