aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2003-07-24 05:58:28 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2003-07-24 05:58:28 +0800
commita238c463ddea2a3ddb3a530c75a3a7e1083c9c2d (patch)
tree2b53e3235c7067bf8ab94dd3ede84f54cf811809 /shell/Makefile.am
parent0dd1d18f1ab6609c1c38f9e97a0702cc71ce2705 (diff)
downloadgsoc2013-evolution-a238c463ddea2a3ddb3a530c75a3a7e1083c9c2d.tar
gsoc2013-evolution-a238c463ddea2a3ddb3a530c75a3a7e1083c9c2d.tar.gz
gsoc2013-evolution-a238c463ddea2a3ddb3a530c75a3a7e1083c9c2d.tar.bz2
gsoc2013-evolution-a238c463ddea2a3ddb3a530c75a3a7e1083c9c2d.tar.lz
gsoc2013-evolution-a238c463ddea2a3ddb3a530c75a3a7e1083c9c2d.tar.xz
gsoc2013-evolution-a238c463ddea2a3ddb3a530c75a3a7e1083c9c2d.tar.zst
gsoc2013-evolution-a238c463ddea2a3ddb3a530c75a3a7e1083c9c2d.zip
Create a new EShellWindow and show it.
* main.c (idle_cb): Create a new EShellWindow and show it. * e-storage.c: New signal "async_open_folder". (impl_async_open_folder): Removed. (class_init): Declare new signal. * e-shell.c (setup_components): Don't actually activate any components. * e-storage-browser.c, e-storage-browser.h: New. * e-shell-window.c, e-shell-window.h: New. * e-shell-marshal.list: Add an entry for NONE:STRING,POINTER,POINTER. * Evolution.idl: Include Evolution-Component.idl. * Evolution-Component.idl: New interface for Evolution components. svn path=/trunk/; revision=21925
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am43
1 files changed, 26 insertions, 17 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 1631ccdef0..27430babee 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -29,6 +29,7 @@ noinst_PROGRAMS = evolution evolution-test-component
IDLS = \
Evolution-Activity.idl \
Evolution-ConfigControl.idl \
+ Evolution-Component.idl \
Evolution-Offline.idl \
Evolution-Session.idl \
Evolution-Shell.idl \
@@ -113,19 +114,28 @@ eshellincludedir = $(privincludedir)/shell
eshellinclude_HEADERS = \
Evolution.h \
- e-folder.h \
+ e-corba-storage.h \
+ e-folder-dnd-bridge.h \
e-folder-list.h \
e-folder-tree.h \
+ e-folder-type-registry.h \
+ e-folder.h \
+ e-icon-factory.h \
e-shell-corba-icon-utils.h \
+ e-shell-utils.h \
+ e-storage-browser.h \
+ e-storage-set-view.h \
+ e-storage-set.h \
+ e-storage.h \
evolution-activity-client.h \
evolution-config-control.h \
evolution-folder-selector-button.h \
evolution-session.h \
evolution-shell-client.h \
evolution-shell-component-client.h \
- evolution-shell-component.h \
evolution-shell-component-dnd.h \
evolution-shell-component-utils.h \
+ evolution-shell-component.h \
evolution-shell-view.h \
evolution-storage-listener.h \
evolution-storage-set-view-listener.h \
@@ -134,25 +144,34 @@ eshellinclude_HEADERS = \
libeshell_la_SOURCES = \
$(IDL_GENERATED) \
- e-folder.c \
+ e-corba-storage.c \
+ e-folder-dnd-bridge.c \
e-folder-list.c \
e-folder-tree.c \
+ e-folder-type-registry.c \
+ e-folder.c \
+ e-icon-factory.c \
e-shell-corba-icon-utils.c \
+ e-shell-marshal.c \
+ e-shell-utils.c \
+ e-storage-browser.c \
+ e-storage-set-view.c \
+ e-storage-set.c \
+ e-storage.c \
evolution-activity-client.c \
evolution-config-control.c \
evolution-folder-selector-button.c \
evolution-session.c \
evolution-shell-client.c \
evolution-shell-component-client.c \
- evolution-shell-component.c \
evolution-shell-component-dnd.c \
evolution-shell-component-utils.c \
+ evolution-shell-component.c \
evolution-shell-view.c \
evolution-storage-listener.c \
evolution-storage-set-view-listener.c \
evolution-storage.c \
evolution-wizard.c \
- e-shell-marshal.c \
$(eshellinclude_HEADERS)
libeshell_la_LIBADD = \
@@ -179,14 +198,8 @@ evolution_SOURCES = \
e-corba-storage-registry.h \
e-corba-storage.c \
e-corba-storage.h \
- e-folder-dnd-bridge.c \
- e-folder-dnd-bridge.h \
- e-folder-type-registry.c \
- e-folder-type-registry.h \
e-history.c \
e-history.h \
- e-icon-factory.c \
- e-icon-factory.h \
e-local-folder.c \
e-local-folder.h \
e-local-storage.c \
@@ -234,6 +247,8 @@ evolution_SOURCES = \
e-shell-view-menu.h \
e-shell-view.c \
e-shell-view.h \
+ e-shell-window.c \
+ e-shell-window.h \
e-shell.c \
e-shell.h \
e-shortcuts-view-model.c \
@@ -244,12 +259,6 @@ evolution_SOURCES = \
e-shortcuts.h \
e-splash.c \
e-splash.h \
- e-storage-set-view.c \
- e-storage-set-view.h \
- e-storage-set.c \
- e-storage-set.h \
- e-storage.c \
- e-storage.h \
e-task-bar.c \
e-task-bar.h \
e-task-widget.c \