aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2003-04-08 00:08:11 +0800
committerDan Winship <danw@src.gnome.org>2003-04-08 00:08:11 +0800
commita14c9abfebfd4c5dbc22cac4d3b50dec580fc6fc (patch)
tree9f8a4b11e98ff95e939fee24c036962f71c3052c /shell/Makefile.am
parentb743a6f7ee532050df61a07d820c781c3bd968f7 (diff)
downloadgsoc2013-evolution-a14c9abfebfd4c5dbc22cac4d3b50dec580fc6fc.tar
gsoc2013-evolution-a14c9abfebfd4c5dbc22cac4d3b50dec580fc6fc.tar.gz
gsoc2013-evolution-a14c9abfebfd4c5dbc22cac4d3b50dec580fc6fc.tar.bz2
gsoc2013-evolution-a14c9abfebfd4c5dbc22cac4d3b50dec580fc6fc.tar.lz
gsoc2013-evolution-a14c9abfebfd4c5dbc22cac4d3b50dec580fc6fc.tar.xz
gsoc2013-evolution-a14c9abfebfd4c5dbc22cac4d3b50dec580fc6fc.tar.zst
gsoc2013-evolution-a14c9abfebfd4c5dbc22cac4d3b50dec580fc6fc.zip
Substitute version number into the evolution binary name in the server
* Makefile.am ($(server_in_files)): Substitute version number into the evolution binary name in the server file (INCLUDES): define EVOLUTION_TOOLSDIR * GNOME_Evolution_Shell.server.in.in: Clean up server names. Add "-@VERSION@" to the end of the shell binary name * main.c (main): if KILL_PROCESS_CMD is defined, add a --force-shutdown argument that runs killev and exits. svn path=/trunk/; revision=20702
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index defd6266c3..5fc76a57f5 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -14,6 +14,7 @@ INCLUDES = \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
-DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
-DEVOLUTION_UIDIR=\""$(evolutionuidir)"\" \
+ -DEVOLUTION_TOOLSDIR=\""$(privlibexecdir)"\" \
-DPREFIX=\""$(prefix)"\" \
-DSYSCONFDIR=\""$(sysconfdir)"\" \
-DDATADIR=\""$(datadir)"\" \
@@ -289,7 +290,9 @@ install-test-component: evolution-test-component
server_in_files = GNOME_Evolution_Shell.server.in.in
server_DATA = $(server_in_files:.server.in.in=.server)
$(server_in_files:.server.in.in=.server.in): $(server_in_files)
- sed -e "s|\@BINDIR\@|$(bindir)|" $< > $@
+ sed -e "s|\@BINDIR\@|$(bindir)|" \
+ -e "s|\@VERSION\@|$(BASE_VERSION)|" \
+ $< > $@
etspec_DATA = e-storage-set-view.etspec