aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorJP Rosevear <jpr@ximian.com>2004-01-11 14:45:44 +0800
committerJP Rosevear <jpr@src.gnome.org>2004-01-11 14:45:44 +0800
commit6e209f9bf47dd5d0d2323824ccf074f48558e7af (patch)
tree0f37f93e2e671245c76ab312976a31f5c3849da3 /shell/Makefile.am
parentd7bb9b315af40592aab3fa992d91ca09bd7a2983 (diff)
downloadgsoc2013-evolution-6e209f9bf47dd5d0d2323824ccf074f48558e7af.tar
gsoc2013-evolution-6e209f9bf47dd5d0d2323824ccf074f48558e7af.tar.gz
gsoc2013-evolution-6e209f9bf47dd5d0d2323824ccf074f48558e7af.tar.bz2
gsoc2013-evolution-6e209f9bf47dd5d0d2323824ccf074f48558e7af.tar.lz
gsoc2013-evolution-6e209f9bf47dd5d0d2323824ccf074f48558e7af.tar.xz
gsoc2013-evolution-6e209f9bf47dd5d0d2323824ccf074f48558e7af.tar.zst
gsoc2013-evolution-6e209f9bf47dd5d0d2323824ccf074f48558e7af.zip
proper server file for test components
2004-01-11 JP Rosevear <jpr@ximian.com> * GNOME_Evolution_Test.server.in.in: proper server file for test components * Makefile.am: allow the test component to be built and installed * evolution-test-component.[hc]: new test component to match current api svn path=/trunk/; revision=24151
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am30
1 files changed, 19 insertions, 11 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index eb2244edcf..f152450f9d 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -173,17 +173,25 @@ evolution_LDADD = \
# Test component
-# evolution_test_component_SOURCES = \
-# evolution-test-component.c
+if ENABLE_TEST_COMPONENT
+component_LTLIBRARIES = libevolution-test.la
+endif
+
+libevolution_test_la_SOURCES = \
+ evolution-test-component.c \
+ evolution-test-component.h
-# evolution_test_component_LDADD = \
-# libeshell.la \
-# $(SHELL_LIBS)
+libevolution_test_la_LIBADD = \
+ libeshell.la \
+ $(SHELL_LIBS)
-# install-test-component: evolution-test-component
-# $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) evolution-test-component $(DESTDIR)$(bindir)/evolution-test-component
-# $(mkinstalldirs) $(DESTDIR)$(serverdir)
-# $(INSTALL_DATA) $(srcdir)/GNOME_Evolution_TestComponent.server $(DESTDIR)$(serverdir)/GNOME_Evolution_TestComponent.server
+libevolution_test_la_LDFLAGS = -avoid-version -module
+
+if ENABLE_TEST_COMPONENT
+testserver_in_files = GNOME_Evolution_Test.server.in.in
+testserver_DATA = $(testserver_in_files:.server.in.in=_$(BASE_VERSION).server)
+testserverdir = $(serverdir)
+endif
# Misc stuff
@@ -245,11 +253,11 @@ MARSHAL_GENERATED = e-shell-marshal.c e-shell-marshal.h
EXTRA_DIST = \
$(IDLS) \
$(server_in_files) \
+ GNOME_Evolution_Test.server.in.in \
$(etspec_DATA) \
$(schema_DATA) \
$(icons) \
ChangeLog.pre-1-4 \
- GNOME_Evolution_TestComponent.server \
e-shell-marshal.list \
evolution-nognome.in
@@ -267,7 +275,7 @@ evolution.pure: evolution
endif
-BUILT_SOURCES = $(IDL_GENERATED) $(SELECT_NAMES_IDL_GENERATED) $(MARSHAL_GENERATED) $(server_DATA) $(DATASERVER_IDL_GENERATED)
+BUILT_SOURCES = $(IDL_GENERATED) $(SELECT_NAMES_IDL_GENERATED) $(MARSHAL_GENERATED) $(server_DATA) $(testserver_DATA) $(DATASERVER_IDL_GENERATED)
CLEANFILES = $(BUILT_SOURCES)
dist-hook: