aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2003-03-29 05:52:31 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2003-03-29 05:52:31 +0800
commit583bbec280424953b29502d0e8ba6e0e0947853b (patch)
treedfea9e405173e6f948880118759a74dc5e50c5dc /shell/Makefile.am
parent2fee911d3a9ea70c4bc4b24a49232d89e8fcf6ba (diff)
downloadgsoc2013-evolution-583bbec280424953b29502d0e8ba6e0e0947853b.tar
gsoc2013-evolution-583bbec280424953b29502d0e8ba6e0e0947853b.tar.gz
gsoc2013-evolution-583bbec280424953b29502d0e8ba6e0e0947853b.tar.bz2
gsoc2013-evolution-583bbec280424953b29502d0e8ba6e0e0947853b.tar.lz
gsoc2013-evolution-583bbec280424953b29502d0e8ba6e0e0947853b.tar.xz
gsoc2013-evolution-583bbec280424953b29502d0e8ba6e0e0947853b.tar.zst
gsoc2013-evolution-583bbec280424953b29502d0e8ba6e0e0947853b.zip
(kill_old_wombat): New.
(kill_wombat): New. (idle_cb): Call kill_old_wombat(). svn path=/trunk/; revision=20565
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index c81d66ee67..defd6266c3 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -78,6 +78,27 @@ $(SELECT_NAMES_IDL_GENERATED_H): $(SELECT_NAMES_IDL)
$(SELECT_NAMES_IDL_GENERATED_C): $(SELECT_NAMES_IDL_GENERATED_H)
+# Wombat CORBA stuff
+
+WOMBAT_IDL = \
+ $(top_srcdir)/wombat/Evolution-Wombat.idl
+
+WOMBAT_IDL_GENERATED_H = \
+ Evolution-Wombat.h
+
+WOMBAT_IDL_GENERATED_C = \
+ Evolution-Wombat-common.c \
+ Evolution-Wombat-skels.c \
+ Evolution-Wombat-stubs.c
+
+WOMBAT_IDL_GENERATED = $(WOMBAT_IDL_GENERATED_C) $(WOMBAT_IDL_GENERATED_H)
+
+$(WOMBAT_IDL_GENERATED_H): $(WOMBAT_IDL)
+ $(ORBIT_IDL) -I $(srcdir) $(IDL_INCLUDES) $(WOMBAT_IDL)
+
+$(WOMBAT_IDL_GENERATED_C): $(WOMBAT_IDL_GENERATED_H)
+
+
# IDL install
idl_DATA = $(IDLS)
@@ -140,6 +161,7 @@ libeshell_la_LIBADD = \
evolution_SOURCES = \
$(SELECT_NAMES_IDL_GENERATED) \
+ $(WOMBAT_IDL_GENERATED) \
e-activity-handler.c \
e-activity-handler.h \
e-component-info.c \