aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorMichael Meeks <michael@ximian.com>2001-04-14 16:02:59 +0800
committerMichael Meeks <michael@src.gnome.org>2001-04-14 16:02:59 +0800
commit04fac44de1b9b0106ef95b6bf6cfc2d877b01fd2 (patch)
treeb5e5eb3fca54a50b8643bfdf7125fef9b272e6dd /shell/Makefile.am
parenta5e6e0b5f3e06eee5726edfe276c5d3c65bb155c (diff)
downloadgsoc2013-evolution-04fac44de1b9b0106ef95b6bf6cfc2d877b01fd2.tar
gsoc2013-evolution-04fac44de1b9b0106ef95b6bf6cfc2d877b01fd2.tar.gz
gsoc2013-evolution-04fac44de1b9b0106ef95b6bf6cfc2d877b01fd2.tar.bz2
gsoc2013-evolution-04fac44de1b9b0106ef95b6bf6cfc2d877b01fd2.tar.lz
gsoc2013-evolution-04fac44de1b9b0106ef95b6bf6cfc2d877b01fd2.tar.xz
gsoc2013-evolution-04fac44de1b9b0106ef95b6bf6cfc2d877b01fd2.tar.zst
gsoc2013-evolution-04fac44de1b9b0106ef95b6bf6cfc2d877b01fd2.zip
Do this everywhere, also fixup CLEANFILES
Do this everywhere, also fixup CLEANFILES 2001-04-14 Michael Meeks <michael@ximian.com> * Makefile.am (dist-hook): remove built sources from dist. svn path=/trunk/; revision=9309
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index d52972c02a..b6eb99cba7 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -13,8 +13,6 @@ INCLUDES = \
-DEVOLUTION_GLADEDIR=\"$(datadir)/evolution/glade\" \
-DG_LOG_DOMAIN=\"evolution-shell\"
-CLEANFILES = $(IDL_GENERATED)
-
# CORBA stuff
IDLS = \
@@ -162,3 +160,10 @@ evolution.pure: evolution
$(PLINK) $(evolution_LDFLAGS) $(evolution_OBJECTS) $(evolution_LDADD) $(LIBS)
endif
+
+CLEANFILES += $(IDL_GENERATED)
+BUILT_SOURCES = $(IDL_GENERATED)
+
+dist-hook:
+ cd $(distdir); rm -f $(BUILT_SOURCES)
+