aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2003-02-06 06:25:18 +0800
committerDan Winship <danw@src.gnome.org>2003-02-06 06:25:18 +0800
commitfefb7820db99e63564395beeec82949ccb0e3b9f (patch)
tree2d33e3a41b20dfa424a0a7a1bb4a1a02ca6889db /shell/Makefile.am
parentfe4da718f0ae5a8a0fbf7249acf3f235113df792 (diff)
downloadgsoc2013-evolution-fefb7820db99e63564395beeec82949ccb0e3b9f.tar
gsoc2013-evolution-fefb7820db99e63564395beeec82949ccb0e3b9f.tar.gz
gsoc2013-evolution-fefb7820db99e63564395beeec82949ccb0e3b9f.tar.bz2
gsoc2013-evolution-fefb7820db99e63564395beeec82949ccb0e3b9f.tar.lz
gsoc2013-evolution-fefb7820db99e63564395beeec82949ccb0e3b9f.tar.xz
gsoc2013-evolution-fefb7820db99e63564395beeec82949ccb0e3b9f.tar.zst
gsoc2013-evolution-fefb7820db99e63564395beeec82949ccb0e3b9f.zip
Define EVOLUTION_IMAGES using $(imagesdir). Define EVOLUTION_GLADEDIR
* Makefile.am (INCLUDES): Define EVOLUTION_IMAGES using $(imagesdir). Define EVOLUTION_GLADEDIR using $(gladedir) (eshellincludedir): Define in terms of $(privincludedir) (evolution_LDFLAGS): Remove this. gmodule-2's LDFLAGS include the equivalent of -export-dynamic for us. (serverdir, etspecdir): Remove. Defined in configure.in now. * e-folder.c: #include <string.h> * e-corba-config-page.c: Likewise * e-shell-config.c: Likewise * e-shell-folder-creation-dialog.c: Likewise * e-shell-folder-title-bar.c: Likewise * e-shell-startup-wizard.c: Likewise * evolution-activity-client.c: Likewise. * evolution-shell-component-client.c: Likewise * evolution-shell-component-utils.c: Likewise * evolution-storage.c: Likewise * evolution-test-component.c: Likewise * e-shortcuts-view.c (destroy_group_cb): Remove unused variable * importer/Makefile.am (INCLUDES): Remove -I$(includedir). Define EVOLUTION_GLADEDIR using $(gladedir). (libevolution_importerincludedir): Define in terms of $(privincludedir) (gladedir): Removed. Defined in configure.in now. * glade/Makefile.am (gladedir): Likewise svn path=/trunk/; revision=19774
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am44
1 files changed, 20 insertions, 24 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 882737f569..32e4dadf36 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -1,24 +1,24 @@
SUBDIRS = glade importer
-INCLUDES = \
- -DG_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED \
- -DBONOBO_DISABLE_DEPRECATED -DGNOME_DISABLE_DEPRECATED \
- -I$(top_srcdir)/widgets \
- -I$(top_srcdir)/widgets/misc \
- -I$(top_srcdir)/libical/src/libical \
- -I$(top_builddir)/libical/src/libical \
- -I$(top_srcdir) \
- -DEVOLUTION_IMAGES=\""$(datadir)/evolution-$(BASE_VERSION)/images"\" \
- -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
- -DEVOLUTION_DATADIR=\""$(datadir)"\" \
- -DEVOLUTION_GLADEDIR=\"$(datadir)/evolution-$(BASE_VERSION)/glade\" \
- -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
- -DEVOLUTION_UIDIR=\""$(evolutionuidir)"\" \
- -DPREFIX=\"$(prefix)\" \
- -DSYSCONFDIR=\""$(sysconfdir)"\" \
- -DDATADIR=\""$(datadir)"\" \
- -DLIBDIR=\""$(datadir)"\" \
- -DG_LOG_DOMAIN=\"evolution-shell\" \
+INCLUDES = \
+ -DG_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED \
+ -DBONOBO_DISABLE_DEPRECATED -DGNOME_DISABLE_DEPRECATED \
+ -I$(top_srcdir)/widgets \
+ -I$(top_srcdir)/widgets/misc \
+ -I$(top_srcdir)/libical/src/libical \
+ -I$(top_builddir)/libical/src/libical \
+ -I$(top_srcdir) \
+ -DEVOLUTION_IMAGES=\""$(imagesdir)"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DEVOLUTION_DATADIR=\""$(datadir)"\" \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
+ -DEVOLUTION_UIDIR=\""$(evolutionuidir)"\" \
+ -DPREFIX=\""$(prefix)"\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DLIBDIR=\""$(datadir)"\" \
+ -DG_LOG_DOMAIN=\"evolution-shell\" \
$(SHELL_CFLAGS)
noinst_PROGRAMS = evolution evolution-test-component
@@ -87,7 +87,7 @@ idl_DATA = $(IDLS)
privlib_LTLIBRARIES = \
libeshell.la
-eshellincludedir = $(includedir)/evolution-$(BASE_VERSION)/shell
+eshellincludedir = $(privincludedir)/shell
eshellinclude_HEADERS = \
Evolution.h \
@@ -245,8 +245,6 @@ evolution_LDADD = \
$(top_builddir)/libical/src/libical/libical-evolution.la \
$(SHELL_LIBS)
-evolution_LDFLAGS = -export-dynamic
-
# Test component
evolution_test_component_SOURCES = \
@@ -263,13 +261,11 @@ install-test-component: evolution-test-component
# Misc stuff
-serverdir = $(libdir)/bonobo/servers
server_in_files = GNOME_Evolution_Shell.server.in.in
server_DATA = $(server_in_files:.server.in.in=.server)
$(server_in_files:.server.in.in=.server.in): $(server_in_files)
sed -e "s|\@BINDIR\@|$(bindir)|" $< > $@
-etspecdir = $(datadir)/evolution-$(BASE_VERSION)/etspec/
etspec_DATA = e-storage-set-view.etspec
@INTLTOOL_SERVER_RULE@