aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2004-06-11 00:30:15 +0800
committerDan Winship <danw@src.gnome.org>2004-06-11 00:30:15 +0800
commit4ba6a25075f9cee4d9aafefe1d77a14e2734300d (patch)
tree1d0e071b5f3fafce7988c2dc54273a685f0279d9 /shell/Makefile.am
parentf07379abc5bfc6b9d0b46b6789675447faff4503 (diff)
downloadgsoc2013-evolution-4ba6a25075f9cee4d9aafefe1d77a14e2734300d.tar
gsoc2013-evolution-4ba6a25075f9cee4d9aafefe1d77a14e2734300d.tar.gz
gsoc2013-evolution-4ba6a25075f9cee4d9aafefe1d77a14e2734300d.tar.bz2
gsoc2013-evolution-4ba6a25075f9cee4d9aafefe1d77a14e2734300d.tar.lz
gsoc2013-evolution-4ba6a25075f9cee4d9aafefe1d77a14e2734300d.tar.xz
gsoc2013-evolution-4ba6a25075f9cee4d9aafefe1d77a14e2734300d.tar.zst
gsoc2013-evolution-4ba6a25075f9cee4d9aafefe1d77a14e2734300d.zip
Remove no-longer-used stuff
* check-empty.xpm, check-filled.xpm, check-missing.xpm: * e-shell-config-autocompletion.[ch]: * e-shell-config-default-folders.[ch]: * e-shell-config-folder-settings.[ch]: * e-shell-config-offline.[ch]: * e-shell-config.[ch]: * e-shell-folder-creation-dialog.[ch]: * e-shell-shared-folder-picker-dialog.[ch]: * e-storage-set-store.[ch]: * e-storage-set-view-checkboxes.etstate: * e-storage-set-view-no-checkboxes.etstate: * e-storage-set-view.etspec: * e-uri-schema-registry.[ch]: * evolution-activity-client.c: * evolution-storage-set-view-factory.[ch]: * evolution-storage-set-view.[ch]: * glade/e-folder-list.glade: * glade/e-shell-config-default-folders.glade: * glade/e-shell-folder-creation-dialog.glade: * glade/e-shell-shared-folder-picker-dialog.glade: Remove no-longer-used stuff * README: Remove this, since it's more confusing than true now. * Evolution-Offline.idl, Evolution-common.idl: Remove GNOME_Evolution_Folder, and references to it. * e-active-connection-dialog.glade: * evolution-startup-wizard.glade: Move the last two remaining files from ./glade/ up to here. * glade/*: Gone. * Makefile.am, .cvsignore: update for the above svn path=/trunk/; revision=26286
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am43
1 files changed, 8 insertions, 35 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index fa3c86f9ff..527b2d92f1 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = glade importer
+SUBDIRS = importer
INCLUDES = \
-I$(top_srcdir)/widgets \
@@ -8,7 +8,6 @@ INCLUDES = \
-DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
-DEVOLUTION_DATADIR=\""$(datadir)"\" \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
- -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
-DEVOLUTION_HELPDIR=\""$(evolutionhelpdir)"\" \
-DEVOLUTION_UIDIR=\""$(evolutionuidir)"\" \
-DEVOLUTION_TOOLSDIR=\""$(privlibexecdir)"\" \
@@ -50,27 +49,6 @@ $(IDL_GENERATED_H): $(IDLS)
$(IDL_GENERATED_C): $(IDL_GENERATED_H)
-# SelectNames CORBA stuff
-
-SELECT_NAMES_IDL = \
- $(top_srcdir)/addressbook/gui/component/select-names/Evolution-Addressbook-SelectNames.idl
-
-SELECT_NAMES_IDL_GENERATED_H = \
- Evolution-Addressbook-SelectNames.h
-
-SELECT_NAMES_IDL_GENERATED_C = \
- Evolution-Addressbook-SelectNames-common.c \
- Evolution-Addressbook-SelectNames-skels.c \
- Evolution-Addressbook-SelectNames-stubs.c
-
-SELECT_NAMES_IDL_GENERATED = $(SELECT_NAMES_IDL_GENERATED_C) $(SELECT_NAMES_IDL_GENERATED_H)
-
-$(SELECT_NAMES_IDL_GENERATED_H): $(SELECT_NAMES_IDL)
- $(ORBIT_IDL) -I $(srcdir) $(IDL_INCLUDES) $(SELECT_NAMES_IDL)
-
-$(SELECT_NAMES_IDL_GENERATED_C): $(SELECT_NAMES_IDL_GENERATED_H)
-
-
# Data Server CORBA stuff
DATASERVER_IDL_GENERATED_H = \
Evolution-DataServer.h
@@ -126,7 +104,6 @@ libeshell_la_LIBADD = \
# Evolution executable
evolution_SOURCES = \
- $(SELECT_NAMES_IDL_GENERATED) \
$(DATASERVER_IDL_GENERATED) \
e-component-registry.c \
e-component-registry.h \
@@ -139,10 +116,10 @@ evolution_SOURCES = \
e-shell-constants.h \
e-shell-folder-title-bar.c \
e-shell-folder-title-bar.h \
- e-shell-offline-handler.c \
- e-shell-offline-handler.h \
e-shell-importer.c \
e-shell-importer.h \
+ e-shell-offline-handler.c \
+ e-shell-offline-handler.h \
e-shell-settings-dialog.c \
e-shell-settings-dialog.h \
e-shell-startup-wizard.c \
@@ -202,12 +179,9 @@ errordir = $(privdatadir)/errors
%.xml.h: %.xml
$(top_builddir)/e-util/e-error-tool $^
-etspec_DATA = e-storage-set-view.etspec
-
-icons = \
- check-empty.xpm \
- check-filled.xpm \
- check-missing.xpm
+glade_DATA = \
+ e-active-connection-dialog.glade \
+ evolution-startup-wizard.glade
# GConf schemas
@@ -258,9 +232,8 @@ EXTRA_DIST = \
GNOME_Evolution_Test.server.in.in \
$(error_DATA) \
$(error_i18n) \
- $(etspec_DATA) \
+ $(glade_DATA) \
$(schema_DATA) \
- $(icons) \
ChangeLog.pre-1-4 \
e-shell-marshal.list \
evolution-nognome.in
@@ -279,7 +252,7 @@ evolution.pure: evolution
endif
-BUILT_SOURCES = $(IDL_GENERATED) $(SELECT_NAMES_IDL_GENERATED) $(MARSHAL_GENERATED) $(server_DATA) $(testserver_DATA) $(DATASERVER_IDL_GENERATED) $(error_i18n)
+BUILT_SOURCES = $(IDL_GENERATED) $(MARSHAL_GENERATED) $(server_DATA) $(testserver_DATA) $(DATASERVER_IDL_GENERATED) $(error_i18n)
CLEANFILES = $(BUILT_SOURCES)
dist-hook: