aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@src.gnome.org>2008-07-17 03:37:02 +0800
committerMatthew Barnes <mbarnes@src.gnome.org>2008-07-17 03:37:02 +0800
commit03a3e6f84638c62c7848eee4d6f71cc4b1a7c1b8 (patch)
tree39d9a26ea8438f161ca413b197cf62a070b21385 /shell/Makefile.am
parentac0c655f3f2a8e47b0cca877aabae66421c58187 (diff)
downloadgsoc2013-evolution-03a3e6f84638c62c7848eee4d6f71cc4b1a7c1b8.tar
gsoc2013-evolution-03a3e6f84638c62c7848eee4d6f71cc4b1a7c1b8.tar.gz
gsoc2013-evolution-03a3e6f84638c62c7848eee4d6f71cc4b1a7c1b8.tar.bz2
gsoc2013-evolution-03a3e6f84638c62c7848eee4d6f71cc4b1a7c1b8.tar.lz
gsoc2013-evolution-03a3e6f84638c62c7848eee4d6f71cc4b1a7c1b8.tar.xz
gsoc2013-evolution-03a3e6f84638c62c7848eee4d6f71cc4b1a7c1b8.tar.zst
gsoc2013-evolution-03a3e6f84638c62c7848eee4d6f71cc4b1a7c1b8.zip
Disable all components and plugins. Begin rewriting the shell.
svn path=/branches/kill-bonobo/; revision=35748
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am24
1 files changed, 14 insertions, 10 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 9654dbf814..18f092ac7d 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -13,6 +13,7 @@ INCLUDES = \
-DEVOLUTION_DATADIR=\""$(datadir)"\" \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
-DEVOLUTION_HELPDIR=\""$(evolutionhelpdir)"\" \
+ -DEVOLUTION_MODULEDIR=\""$(evolutionmoduledir)"\" \
-DEVOLUTION_UIDIR=\""$(evolutionuidir)"\" \
-DEVOLUTION_TOOLSDIR=\""$(privlibexecdir)"\" \
-DPREFIX=\""$(prefix)"\" \
@@ -89,10 +90,13 @@ eshellincludedir = $(privincludedir)/shell
eshellinclude_HEADERS = \
Evolution.h \
- e-component-view.h \
+ e-shell-common.h \
+ e-shell-module.h \
+ e-shell-view.h \
+ e-shell-window.h \
+ e-shell-window-actions.h \
e-user-creatable-items-handler.h \
evolution-config-control.h \
- evolution-component.h \
evolution-listener.h \
evolution-shell-component-utils.h \
es-event.h \
@@ -101,8 +105,10 @@ eshellinclude_HEADERS = \
libeshell_la_SOURCES = \
$(IDL_GENERATED) \
$(MARSHAL_GENERATED) \
- e-component-view.c \
- evolution-component.c \
+ e-shell-module.c \
+ e-shell-view.c \
+ e-shell-window.c \
+ e-shell-window-actions.c \
evolution-listener.c \
e-user-creatable-items-handler.c \
evolution-config-control.c \
@@ -132,14 +138,12 @@ evolution_SOURCES = \
e-shell-constants.h \
e-shell-importer.c \
e-shell-importer.h \
+ e-shell-registry.c \
+ e-shell-registry.h \
e-shell-settings-dialog.c \
e-shell-settings-dialog.h \
- e-shell-window-commands.c \
- e-shell-window-commands.h \
- e-shell-window.c \
- e-shell-window.h \
- e-shell-view.c \
- e-shell-view.h \
+ e-shell-window-private.c \
+ e-shell-window-private.h \
e-sidebar.c \
e-sidebar.h \
es-event.c \