aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@src.gnome.org>2007-09-12 03:33:47 +0800
committerMatthew Barnes <mbarnes@src.gnome.org>2007-09-12 03:33:47 +0800
commitb8eefeb931f765e5046244ed98791b7030cec536 (patch)
treeae5f80a0c6d982dc3f1bfe53efbd0cf1fcc97e87 /shell/Makefile.am
parentdec7b2460dd1fc901d87cff50cb81bb514a5aef1 (diff)
downloadgsoc2013-evolution-b8eefeb931f765e5046244ed98791b7030cec536.tar
gsoc2013-evolution-b8eefeb931f765e5046244ed98791b7030cec536.tar.gz
gsoc2013-evolution-b8eefeb931f765e5046244ed98791b7030cec536.tar.bz2
gsoc2013-evolution-b8eefeb931f765e5046244ed98791b7030cec536.tar.lz
gsoc2013-evolution-b8eefeb931f765e5046244ed98791b7030cec536.tar.xz
gsoc2013-evolution-b8eefeb931f765e5046244ed98791b7030cec536.tar.zst
gsoc2013-evolution-b8eefeb931f765e5046244ed98791b7030cec536.zip
Move the test component to "shell/test" so it installs properly (#469992).
svn path=/trunk/; revision=34235
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am35
1 files changed, 7 insertions, 28 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 8eef0ef0df..916acd779b 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -1,3 +1,7 @@
+if ENABLE_TEST_COMPONENT
+SUBDIRS = . test
+endif
+
INCLUDES = \
-I$(top_srcdir)/widgets \
-I$(top_srcdir)/widgets/misc \
@@ -17,8 +21,7 @@ INCLUDES = \
-DLIBDIR=\""$(datadir)"\" \
-DG_LOG_DOMAIN=\"evolution-shell\" \
$(TZDIALOG_CFLAGS) \
- $(SHELL_CFLAGS) \
- $(EVOLUTION_TEST_CFLAGS)
+ $(SHELL_CFLAGS)
noinst_PROGRAMS = evolution
@@ -157,29 +160,6 @@ evolution_LDADD = \
$(TZDIALOG_LIBS) \
$(SHELL_LIBS)
-# Test component
-
-if ENABLE_TEST_COMPONENT
-component_LTLIBRARIES = libevolution-test.la
-endif
-
-libevolution_test_la_SOURCES = \
- $(IDL_GENERATED) \
- evolution-test-component.c \
- evolution-test-component.h
-
-libevolution_test_la_LIBADD = \
- libeshell.la \
- $(EVOLUTION_TEST_LIBS)
-
-libevolution_test_la_LDFLAGS = -avoid-version -module $(NO_UNDEFINED)
-
-if ENABLE_TEST_COMPONENT
-testserver_in_files = GNOME_Evolution_Test.server.in.in
-testserver_DATA = $(testserver_in_files:.server.in.in=.server)
-testserverdir = $(serverdir)
-endif
-
# Misc stuff
server_in_files = GNOME_Evolution_Shell.server.in.in
@@ -223,7 +203,7 @@ install-data-local:
fi
endif
-install-evolution:
+install-evolution: $(install-privsolibLTLIBRARIES)
$(mkinstalldirs) $(DESTDIR)$(bindir)
$(LIBTOOL) --mode=install $(INSTALL_PROGRAM) evolution$(EXEEXT) $(DESTDIR)$(bindir)/evolution$(EXEEXT)
@@ -256,7 +236,6 @@ MARSHAL_GENERATED = e-shell-marshal.c e-shell-marshal.h
EXTRA_DIST = \
$(IDLS) \
$(server_in_files) \
- GNOME_Evolution_Test.server.in.in \
shell.error.xml \
$(glade_DATA) \
$(schema_in_files) \
@@ -278,7 +257,7 @@ evolution.pure: evolution
endif
-BUILT_SOURCES = $(IDL_GENERATED) $(MARSHAL_GENERATED) $(server_DATA) $(testserver_DATA) $(DATASERVER_IDL_GENERATED) $(error_DATA)
+BUILT_SOURCES = $(IDL_GENERATED) $(MARSHAL_GENERATED) $(server_DATA) $(DATASERVER_IDL_GENERATED) $(error_DATA)
CLEANFILES = $(BUILT_SOURCES)
DISTCLEANFILES = $(schema_DATA)