aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2003-01-29 07:20:29 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2003-01-29 07:20:29 +0800
commit83ac1fc7df8942657774cbd75ea063bc7d086809 (patch)
tree879746c4492c213ba241a262000b0d2efd24f209 /shell/Makefile.am
parent9c1d6e6b958dffd39b960ecd7ce55bf6e7b8a4ac (diff)
downloadgsoc2013-evolution-83ac1fc7df8942657774cbd75ea063bc7d086809.tar
gsoc2013-evolution-83ac1fc7df8942657774cbd75ea063bc7d086809.tar.gz
gsoc2013-evolution-83ac1fc7df8942657774cbd75ea063bc7d086809.tar.bz2
gsoc2013-evolution-83ac1fc7df8942657774cbd75ea063bc7d086809.tar.lz
gsoc2013-evolution-83ac1fc7df8942657774cbd75ea063bc7d086809.tar.xz
gsoc2013-evolution-83ac1fc7df8942657774cbd75ea063bc7d086809.tar.zst
gsoc2013-evolution-83ac1fc7df8942657774cbd75ea063bc7d086809.zip
No need for the @true command. ($(IDL_GENERATED_C)): Likewise.
* Makefile.am ($(SELECT_NAMES_IDL_GENERATED_C)): No need for the @true command. ($(IDL_GENERATED_C)): Likewise. (e-shell-marshal.h, e-shell-marshal.c): Use different names for the .tmp files so these can be generated in parallel. * importer/Makefile.am (GNOME_Evolution_Importer-impl.o): Remove unused rule. ($(IDL_GENERATED_C)): Remove useless @true command. (BUILT_SOURCES): Put the .h generated files in here as well. svn path=/trunk/; revision=19674
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am18
1 files changed, 8 insertions, 10 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index aa0838f1bf..882737f569 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -55,7 +55,6 @@ $(IDL_GENERATED_H): $(IDLS)
$(ORBIT_IDL) -I $(srcdir) $(IDL_INCLUDES) $(srcdir)/Evolution.idl
$(IDL_GENERATED_C): $(IDL_GENERATED_H)
- @true
# SelectNames CORBA stuff
@@ -77,7 +76,6 @@ $(SELECT_NAMES_IDL_GENERATED_H): $(SELECT_NAMES_IDL)
$(ORBIT_IDL) -I $(srcdir) $(IDL_INCLUDES) $(SELECT_NAMES_IDL)
$(SELECT_NAMES_IDL_GENERATED_C): $(SELECT_NAMES_IDL_GENERATED_H)
- @true
# IDL install
@@ -300,14 +298,14 @@ install-exec-local:
# GLib marshalling cruft
e-shell-marshal.h: e-shell-marshal.list
- ( @GLIB_GENMARSHAL@ --prefix=e_shell_marshal e-shell-marshal.list --header > e-shell-marshal.tmp \
- && mv e-shell-marshal.tmp e-shell-marshal.h ) \
- || ( rm -f e-shell-marshal.tmp && exit 1 )
+ ( @GLIB_GENMARSHAL@ --prefix=e_shell_marshal e-shell-marshal.list --header > e-shell-marshal.h.tmp \
+ && mv e-shell-marshal.h.tmp e-shell-marshal.h ) \
+ || ( rm -f e-shell-marshal.h.tmp && exit 1 )
e-shell-marshal.c: e-shell-marshal.h
- ( @GLIB_GENMARSHAL@ --prefix=e_shell_marshal e-shell-marshal.list --body > e-shell-marshal.tmp \
- && mv e-shell-marshal.tmp e-shell-marshal.c ) \
- || ( rm -f e-shell-marshal.tmp && exit 1 )
+ ( @GLIB_GENMARSHAL@ --prefix=e_shell_marshal e-shell-marshal.list --body > e-shell-marshal.c.tmp \
+ && mv e-shell-marshal.c.tmp e-shell-marshal.c ) \
+ || ( rm -f e-shell-marshal.c.tmp && exit 1 )
MARSHAL_GENERATED = e-shell-marshal.c e-shell-marshal.h
@@ -338,8 +336,8 @@ evolution.pure: evolution
endif
-CLEANFILES = $(IDL_GENERATED) $(SELECT_NAMES_IDL_GENERATED)
-BUILT_SOURCES = $(IDL_GENERATED_H) $(SELECT_NAMES_IDL_GENERATED_H) $(MARSHAL_GENERATED)
+BUILT_SOURCES = $(IDL_GENERATED) $(SELECT_NAMES_IDL_GENERATED) $(MARSHAL_GENERATED)
+CLEANFILES = $(BUILT_SOURCES)
dist-hook:
cd $(distdir); rm -f $(BUILT_SOURCES)