aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2003-05-20 03:41:05 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2003-05-20 03:41:05 +0800
commitf68ef51327afc9c49b9cf0c71666fca8c3a806a9 (patch)
tree8751a7367279adc3257f409483169ced80e7c402 /shell/Makefile.am
parentb414561327ea8e54606437865f48faf2ffd031e2 (diff)
downloadgsoc2013-evolution-f68ef51327afc9c49b9cf0c71666fca8c3a806a9.tar
gsoc2013-evolution-f68ef51327afc9c49b9cf0c71666fca8c3a806a9.tar.gz
gsoc2013-evolution-f68ef51327afc9c49b9cf0c71666fca8c3a806a9.tar.bz2
gsoc2013-evolution-f68ef51327afc9c49b9cf0c71666fca8c3a806a9.tar.lz
gsoc2013-evolution-f68ef51327afc9c49b9cf0c71666fca8c3a806a9.tar.xz
gsoc2013-evolution-f68ef51327afc9c49b9cf0c71666fca8c3a806a9.tar.zst
gsoc2013-evolution-f68ef51327afc9c49b9cf0c71666fca8c3a806a9.zip
Removed "forced_upgrade" unused variable. (show_development_warning): Put
* main.c: Removed "forced_upgrade" unused variable. (show_development_warning): Put in a DEVELOPMENT_WARNING cpp conditional. (warning_dialog_response_callback): Likewise. (view_map_callback): Likewise. (new_view_created_callback): Likewise. (idle_cb) [DEVELOPMENT_WARNING]: Do not connect new_view_created_callback() to the "new_view" shell signal anymore. * Makefile.am (install-evolution) [DEFAULT_BINARY]: Make a symbolic link from evolution to evolution-$(BASE_VERSION). * e-shell-folder-creation-dialog.c (dialog_data_destroy): g_object_weak_unref shell and dialog if they are not NULL. (dialog_destroy_notify): Set ->dialog to NULL in all cases. svn path=/trunk/; revision=21267
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 9ec1771914..fd608ef3cc 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -318,6 +318,9 @@ install-data-local:
install-evolution:
$(mkinstalldirs) $(DESTDIR)$(bindir)
$(LIBTOOL) --mode=install $(INSTALL_PROGRAM) evolution $(DESTDIR)$(bindir)/evolution-$(BASE_VERSION)
+if DEFAULT_BINARY
+ cd $(DESTDIR)$(bindir) && rm -f evolution && $(LN_S) evolution-$(BASE_VERSION) evolution
+endif
if HAVE_DTAPPINTEGRATE
@@ -332,6 +335,7 @@ install-exec-local: install-evolution
endif
+
# GLib marshalling cruft
e-shell-marshal.h: e-shell-marshal.list